Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hibernate doesn't work in Windows 7 64bit. When I try to hibernate, it just turns off computer and when I turn on it, it doesn't resume and it just starts as 'fresh' again. I updated my drivers. What is the problem? Can you give me a hand? Thank you.

Come on, please help me, I really need hibernate working, 100 of my reputation will go to you. Thanks.

Edit, by the way, my model is: Inspiron N5010. After I hibernate and turn on my computer, it just show Shut down didn't shut down correctly.

share|improve this question
    
Your computer has to support the hardware instructions that make hibernate possible. –  Ramhound Jun 21 '11 at 16:16
    
@Ramhound: so what should I do? –  hey Jun 21 '11 at 16:17
    
Is hibernation enabled?, is there a "hiberfil.sys" file on the root of the C drive? –  Moab Jun 21 '11 at 16:28
    
@Moab: no. . . . –  hey Jun 21 '11 at 16:37
    
Open an elevated command prompt, type "powercfg -h on" no quotes, hit enter, see if it will hibernate now. –  Moab Jun 21 '11 at 17:01
show 15 more comments

7 Answers

up vote 4 down vote accepted
+50

Some ideas for resolving sleep and hibernation problems:

  1. Disconnect any and all unnecessary devices from your PC. Pare it down to the absolute minimum : unplug anything you can disconnect, turn off and unplug the computer from the mains for a few minutes, then reboot. If the problem disappears, add the devices back while testing.
  2. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S3" etc.
  3. Turn off Hybrid sleep, see explanation here (for Vista, but is the same)
  4. The hibernation file is sometimes disabled by disk cleaning, to restore do in cmd run as administrator "powercfg -h on".
  5. You can use the following command to troubleshoot sleep problems and return a detailed report: powercfg -ENERGY

EDIT

The symptoms you describe don't sound right. Your computer might be infected. Better install and deep-scan using several antivirus products in addition to your current one, at least Malwarebytes Anti-Malware, but also possible are Avast and Spybot-S&D.

You can also use an antivirus online scan such as ESET Online Scanner, Trend Micro House Call and Kaspersky Labs Free Virus Scan. Please note that they might require you to use Internet Explorer as your browser as an administrator, and that each scan may take several hours.

If nothing is found, I suggest using sfc /scannow.

The last resort is Repair Install, which will refresh Windows without requiring you to reinstall any of your applications. Afterward, only total reinstall of Windows is left.

If none of these solves the problem, then this is a hardware problem, so I hope your computer is under warranty.

share|improve this answer
    
@harrymc: tried everything, still no working. –  hey Jun 26 '11 at 11:13
    
Did you have any error messages in powercfg ? And how much free disk space do you have on C ? –  harrymc Jun 26 '11 at 11:51
    
@harrymc: it didn't. I have 228Gb left. –  hey Jun 26 '11 at 14:10
    
Have you run Windows Update, including optional updates ? –  harrymc Jun 26 '11 at 14:40
    
Also, please check your settings against How to Troubleshoot a Vista or Windows 7 Sleep Mode Problem. –  harrymc Jun 26 '11 at 14:50
show 4 more comments

Have you tried this hotfix: http://support.microsoft.com/kb/2410477

I would disable hibernation, delete c:\hiberfil.sys, then reenable it. Hiberfil.sys is a hidden file, you will need to enable viewing of hidden files by opening Computer, hitting the ALT key, and going to Tools>Folder Options>View and click "Show hidden files, folder, and drives". You may also want to uncheck "Hide protected operating system files".

This is how to disable and reenable hibernation:

http://www.sevenforums.com/tutorials/819-hibernate-enable-disable.html

Have you updated your graphics driver?

I also found an interesting solution on the Internet: Is your computer using readyboost, and if so, how is the drive formatted? If so, make sure that it is formatted in NTFS.

http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/black-screen-after-hibernation-with-readyboost-sd/1d679969-7888-47c5-b748-6ddebcc2ad76

I would also look at this:

http://www.prevx.com/blog/140/Black-Screen-woes-could-affect-millions-on-Windows--Vista-and-XP.html (this has been updated to include Windows 7).

share|improve this answer
    
@KCotreau: there is no hiberfil.sys file in c:\ although I see some of the other hidden files. –  hey Jun 27 '11 at 22:47
    
I don't see this, but when I try to create file in C:/ via notepad, it says "you can replace". So I guess there is hiberfil.sys, but I don't see it even if I allowed it. And I tried to reenable hibernation, still no working. –  hey Jun 27 '11 at 23:20
    
@hey You can open a command prompt and do "dir hiberfil.sys /ah" minus the quotes to see if it exists. If is does, after you turn off hibernation, do this "attrib -r -s -h hiberfil.sys" then you can delete it and turn hibernation back on. –  KCotreau Jun 27 '11 at 23:34
    
@KCotreau : Unable to change attribute –  hey Jun 28 '11 at 10:22
    
@hey Have you already disabled hibernation and rebooted? You probably cannot change it if it is in use. –  KCotreau Jun 28 '11 at 11:19
show 4 more comments

My issue was similar to this but slightly different; when I hibernate my computer it simply locks the screen (as if I'd pressed Win+L). Weirdly, I solved this issue by giving my system boot partition (the small ~100mb partition that Windows 7 creates during install) a drive letter!

I think in my case the issue may have been originally caused by my cloning an OS between drives and or using EasyBCD to modify the BCD. Normally you wouldn't need to have the boot partition exposed as a drive letter for hibernate to work.

share|improve this answer
add comment

Try that (from http://social.technet.microsoft.com/forums/en-US/itprovistasp/thread/4d74523f-2b9e-4fe7-9b5e-f0153166adcc/):

We have found that sometimes the BCD file may have issues.

You can try this to fix the BCD file.



1. Run CMD.EXE as administrator

2. Run the following command: bcdedit -enum all

   Look for "Resume from Hibernate" in the output from the command above(example below):

   Resume from Hibernate

   ---------------------

   identifier {3d8d3081-33ac-11dc-9a41-806e6f6e6963}

   device partition=C:

   path \Windows\system32\winresume.exe

   description Windows Vista (TM) Enterprise (recovered)

   inherit {resumeloadersettings}

   filedevice partition=C:

   filepath \hiberfil.sys

   pae Yes

   debugoptionenabled No

3. Once you have found it, copy the value for identifier (in this example - {3d8d3081-33ac-11dc-9a41-806e6f6e6963})

4. Run the following command: bcdedit /deletevalue {3d8d3081-33ac-11dc-9a41-806e6f6e6963} inherit

5. Test hibernation.


Thanks,
Darrell Gorter[MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights
share|improve this answer
    
didn't work. –  hey Jun 26 '11 at 10:12
    
it's so difficult to find solution for your issue... have you asked it in other forums yet? do not forget to copy solution here if you find it outside :) –  kokbira Jun 26 '11 at 15:56
add comment

I tried many hints with no result. Then I discovered that my hibernation file size was incorrect. It's surprisingly easy to fix. Launch cmd and type:

powercfg -HIBERNATE -Size 100

... to set hibernation file size to 100% of your RAM (50% is a minimum, according to context help). This command also activates hibernation feature if necessary.

This solved my issue immediately, without reinstalling anything (even without reboot).

share|improve this answer
add comment

I've not seen this happen since the XP days, so this may not be relevant any more, but look in Device Manager and look under Computer, at the top. If it does not say ACPI Based PC, you do not have ACPI enabled in the BIOS. I think you will also need to reinstall Windows if you want to enable it.

share|improve this answer
    
It says "ACPI x64 Based PC" –  hey Jun 25 '11 at 23:12
add comment

I'm surprised everyone has offered solutions but no one has bothered to check the Event Log and the Performance Monitor. Windows 7 comes with tools to check your device drivers, yet we still do things the old fashion way. These will help you narrow things down immensely. Everytime a system starts, shuts off, logs off and hibernates, an entry is recorded in the System Log. I'd check that first by firing up the Event Viewer.

Next I'd fire up the Performance Monitor. Go under Control Panel/Performance Tools/Advanced Tools. This is like the Security Center popup crap you get all the time. Except this is for performance. You'll see the Event Viewer there. Also Windows logs the time it takes for each device driver to wake up and to go to sleep and will flag anything abnormal at the top of the window.

If none of those help, click the Generate System Diagnostic Reports. This will check all your device drivers for you.

If that STILL doesn't help, we can at least eliminate the Device drivers. Now we look for running proccesses that don't want to go to sleep. You can narrow them down by first eliminating all startup programs. Fire up "MSCONFIG." Just type it into the Search box. Select "Selective startup and uncheck Load "startup items."
Next, switch to the Services tab. Check the box "Hide Microsoft Services" then hit Disable all. This will disable all non essential startup services. Now restart the computer. You should have a bare essentials bootup. It is important you do it this way and NOT safe mode.

Then try hibernating. If that is successful, start enabling a group of services and startup programs at a time and keep hibernating.

If even a bare essentials bootup won't hibernate, we can safely say it is a hardware issue.

share|improve this answer
    
nothing helped :( –  hey Jul 1 '11 at 17:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.