Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running VirtualBox on an OS X host, running Windows 7 as a guest. When I connect my iPod, it is mounted by OS X, and recognized by iTunes. However, it appears in VirtualBox "USB Devices" menu as a disabled/not selectable item.

How can I enable my iPod in VirtualBox in order to access it from the Windows 7 guest?

share|improve this question
What happens when you unmount it from OS X and then try to access through VirtualBox? – slhck Jun 21 '11 at 21:35
It is not listed in USB Devices menu. – Joaquim Oliveira Jun 22 '11 at 17:51
up vote 1 down vote accepted

At least on Windows and Ubuntu (I don't have any Apple hardware to test with) - you need to first configure your virtual machine guest with an appropriate USB Filter to capture the device.

The easiest way is by opening the settings page for the VM you want to configure, and go to the USB settings. Click the device icon with a small green plus to have it pre-populate the fields for your ipod, though you will want to clear out all the fields except the Name, Vendor ID and Product ID. Disconnect your ipod and reboot.

Once you have finished rebooting, start up your VM and once it has booted feel free to connect your ipod - with any luck VirtualBox should intercept and capture the USB device and pass it on to your guest instead of allowing the host to communicate with it.

share|improve this answer
Goyuix, adding the iPod in the USB Filter worked perfectly! Thank you! – Joaquim Oliveira Nov 1 '11 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .