Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a batch file that I'd like to run with the Task Scheduler. Running the batch file manually works fine. If the batch file resides on the C:\ drive, task scheduler runs it fine, but if the batch file is on a network drive, it doesn't run. The task scheduler reports that the job finished successfully, but the batch file is not getting run.

I've tried using both the drive mappings and UNC paths. I've also tried changing the scheduler action to "cmd /C Path/To/BatchFile" just to see if that would help.

share|improve this question
    
Is it possibly just a simple problem with the scheduler? Sounds like you're well past that, but hey, simple answers can be admissible. –  Doc Jun 21 '11 at 21:57
    
Are you running the scheduled task as your regular user or as a different user? If the latter, does that user have access to the share where the BAT file resides? Are you typically logged out when the task is supposed to run? Also, is there any chance that you could post some or all of the contents of the batch file in case the problem lies there? –  boot13 Jun 21 '11 at 22:13
    
Have you looked in the event log to see if a reason why is given? –  PhonicUK Sep 6 '12 at 11:12
add comment

1 Answer

Create a batch file on your local C:\ drive that runs the batch file on the network drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.