Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just replaced my hard drive with a SSD. I did a brand new install on the SSD and I received the following error after booting

BOOTMGR image is corrupt. The system cannot boot.

A little configuration for your knowledge. The system used to be a dual boot with XP & Windows 7. After replacing the original startup hard drive with my SSD I changed a setting in the BIOS to AHCI (I have tested changing it back but this did not help). When I look at the stats on the drive in the BIOS, it claims that the SSD is in a raid configuration despite the settings not being configured that way.

Related System Information:

  • Intel 320 Series 80 GB SATA II SSD
  • JetWay JPA78VM3-H-LF AM2+/AM2 AMD
  • 780V HDMI Micro ATX AMD Motherboard
  • AMD Athlon 64 X2
  • 7 GB RAM

I have performed 2 fresh installs to no avail. Also, followed this guide and performed option 1 and 2. I have done bootsec/fixmbr and /fixboot.

So.. any suggestions?

share|improve this question
Have you tried reverting the setting you changed in the BIOS from AHCI to whatever it was before? – paradd0x Jun 22 '11 at 14:11
Yeah I tried that before but it's been a while in the troubleshooting process. I'll give that a try again. – bacord Jun 23 '11 at 3:03
@Thiago-M Yes I reverted the change and it didn't help. – bacord Jun 24 '11 at 13:14
Did you do a complete fresh install or just reformated and reinstalled the windows 7 partition on your disk? – wullxz Jun 24 '11 at 13:25
Leave the drive in AHCI mode. Disable any RAID settings, and disable all unused SATA controllers on the motherboard. Further, it is possible to enable RAID on a by-controller basis in the motherboard. Ensure you have gone through all of the settings, and report back. – Breakthrough Jun 24 '11 at 15:37
up vote 3 down vote accepted

As a follow up to the comments I posted, you should keep your system in AHCI mode for better performance. When troubleshooting issues like this, and to maintain the best possible system performance, you should disable all unnecessary integrated hardware on your motherboard. For example, if you have more then one SATA controller on your motherboard, but are only using one, disable it in the BIOS. Not only will this make the computer boot up faster (less hardware to initialize), it will also use less system resources in the operating system, since it is one less driver to load.

It is also worth mentioning that on modern motherboards, you can enable RAID on a per-controller basis. If you have trouble disabling it for some reason, try to revert the BIOS back to the stock settings and see if that fixes it. Do note that if you have disabled anything, it will be re-enabled after you return the settings back to the defaults.

share|improve this answer

Try out this link. It was very helpful for my friend hope for you will too. And you can try restore point too.

share|improve this answer
Thanks for the suggestions but neither apply to me. Restore point wouldn't work because as I mentioned I have a brand new SSD hard drive (there would be nothing to restore from). I have already performed the steps in that link. – bacord Jun 24 '11 at 17:58

You could try to first clear the CMOS. See this article :
3 Easy Ways to Clear Your Motherboard CMOS Memory
(if your computer supports these methods).

Then you could also try to wipe out your entire hard disk, using tools supplied by the manufacturer, or the free MiniTool Partition Wizard.

Check with the SSD manufacturer (who is whom?) whether a disk driver is supplied for Windows 7 (which is somewhat unlikely), then install Windows 7.

If the installation does not succeed, return your SSD as being defective, and demand a replacement.

share|improve this answer

This may seem like a strange suggestion but have you considered that either the SSD or the motherboard (or both) suffered a hardware failure? Have you tried replacing the SSD with the original drive to confirm that the motherboard can still boot. Have you tried putting the SSD in another machine to confirm that it is working correctly?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .