Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting the following warning:

Unable to verify SSL certificate for api.heroku.com
To disable SSL verification, run with HEROKU_SSL_VERIFY=disable

By searching Google I was able to find a few solutions. One of them says to add HEROKU_SSL_VERIFY=disable to .bashrc. Unfortunately, I am not able to edit that file. When I try I get the following error:

'readonly' option is set (add ! to override)

!wq is used in place of :wq, but no response.

Does anybody have any ideas on how I can fix this?

share|improve this question

migrated from stackoverflow.com Jun 22 '11 at 6:25

This question came from our site for professional and enthusiast programmers.

    
chmod 666 ~/.bashrc might help –  C-Ram Jun 22 '11 at 6:19
2  
I think it's :wq!, not !wq... –  smcphill Jun 22 '11 at 6:19
add comment

3 Answers 3

This is a vim issue, not a file permission issue. If you did not have read permission on the file, you'd see a "Permission denied" error.

Do you invoke vi/vim with the -R option? Are you calling view instead of vi or vim? Do you have set readonly in your .vimrc or in a file in ~/.vim/ftplugin?

In vim you can enter :set noreadonly to unset the readonly flag.

share|improve this answer
    
:set noreadonly solved the problem for me. I wasn't aware of that flag. I was able to modify .bashrc before, so how could it have been set by accident? –  Morlock Feb 7 at 14:46
    
Consider the questions I pose in my answer. Do any apply? –  glenn jackman Feb 7 at 15:28
add comment

It seems that you don't have the write permissions for the .bashrc file. That sounds weird because the file .bashrc under your home directory should be owned by you. Try this command before you edit the file:

chmod +w ~/.bash
share|improve this answer
    
Not a file permission problem: the error message is from vi/vim –  glenn jackman Jun 22 '11 at 10:25
add comment

root@dfyhs5l1:~/cuda/ex/hello# chmod +w ~/.bashrc chmod: changing permissions of `/home/jalal/.bashrc': Operation not permitted

share|improve this answer
    
What is the relation to the question? –  vonbrand Feb 14 '13 at 1:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.