Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using MS Remote Desktop Connection to connect to a Windows XP Pro PC. I can disconnect and return to the same session (apps still running), but this seems to timeout at about an hour or maybe sooner. This is not an innactivity timeout, but the keeping of the same session. This would be on the receiving computer and not the connecting computer (I should be able to switch connectiong computers and connect to the same remote session, but again, there is the timeout issue.)

I'd like to extend the timing out of the session when disconnected. Is there a setting for this?

Edit: Seems our network has a Group setting that the admin had to change. Still trying to find out what it was.

share|improve this question
    
I wrote: "What version of XP are you running? Pro gives easier options to configure this." Of course, on the remote PC, it MUST be Pro since Home does not have this feature....so on to the answer. –  KCotreau Jun 22 '11 at 13:38
add comment

1 Answer

up vote 4 down vote accepted

On the remote XP Pro computer, do this:

Start > Run > gpedit.msc and enter

Navigate to:

Computer Configuration > Administrative Templates > Windows Components > Terminal Services > Sessions

  • Set "Time limit for disconnected sessions" to Enabled > Never

  • Set "Sets a time limit for active Terminal Services sessions" to Enabled > Never

  • Set "Sets a time limit for active but idle Terminal Services sessions" to Enabled > Never

share|improve this answer
    
Terminal Services is not under Windows Components. I'm forwarding this on to an admin since I may not have the rights to view or change this setting. –  JeffO Jun 22 '11 at 13:52
    
@Jeff O You will need to be a local admin on the computer, which you might be. You may also need to add the policy template: Right Click on Administrative Templates and click Add/Remove Templates. Add the system.adm template (the .adm suffix may not be visible on your system depending on the settings). If will probably be in the right directory when you click Add/Remove, but in case you have to navigate to it, it is located in c:\Windows\inf by default. –  KCotreau Jun 22 '11 at 14:00
    
I don't think this is going to work. I found this in the settings. Set time limit for disconnected sessions. Note: This setting does not apply to console sessions such as Remote Desktop sessions with computers running Windows XP Professional. –  JeffO Jun 23 '11 at 12:42
    
Jeff O I would still set the settings as I described: You have nothing to lose by trying. It would not be the first time something worked that possibly was not supposed to. For the record, I am used to configuring it on a server, where that setting applies...thanks for pointing out that it may not work. –  KCotreau Jun 23 '11 at 14:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.