Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created a sparsebundle just as suggested at http://www.readynas.com/?p=253; however, Time Machine fails to recognize the mounted image. The sparseimage is stored on an external drive, and I already executed:

defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

I have also verified that the naming format of the sparsebundle is: MachineName_.sparsebundle. I'm running the latest version of Snow Leopard (10.6.7).

share|improve this question
    
It's unsupported by Apple and Snow Leopard didn't exist when that tutorial was written. Why do you expect it to still work after a major upgrade of the OS? – Daniel Beck Jun 24 '11 at 10:11

Time Machine backups are a nightmare on NAS, however this is what I did with a NetGear Stora:

In Finder -> Go -> Connect to server.

enter your NAS address including username and password, like this:

smb://username:password@192.168.0.1/ *or whatever your volume's IP is.*

then select to mount the volume of where you want to keep your sparse bundle image.

Now open the disk utility, and create a sparse bundle with the following settings:

  • Name: Backup (or whatever)
  • Size: 300GB (or whatever)
  • Format: Mac OS Extended (Journaled)
  • Encryption: none
  • Partition: No partition map
  • Image Format: sparse bundle disk image
  • Save As: yourcomputername.sparsebundle (e.g.: Toms-MacBook-Pro.sparsebundle)

After you've done all that copy it to your backup volume and open Time Machine's preferences

Click on Select Disk and choose the volume that you want to backup to.

======

A couple of suggestions:

  1. Follow this screencast that i made to auto mount your volume on start up http://www.youtube.com/watch?v=2vhcmEd0Y8o

  2. Do not upgrade to OSX Lion when it comes out, since at least for my Netgear's Stora the Time Machine did not work and i ended up buying a Time Capsule, check first on the ReadyNAS forums.

share|improve this answer

As far as I know, the name of the bundle must be MachineName_MACAddress.sparsebundle, not MachineName_.sparsebundle.

share|improve this answer
1  
That used to be the case, but now (at a guess, since Snow Leopard) MachineName.sparsebundle is correct. – Scott Jul 6 '11 at 21:20

The Sparsebundle should be called [Machine name].sparsebundle. No trailing underscore.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .