Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've edited my hosts file in a Windows 7 VM, but it doesn't work in IE. It works with Firefox, though. I hope this itemized list will help more than a verbose description.

Environment

  • Windows 7 in a VirtualBox VM, Linux (ArchLinux) host
  • VM has a bridged network adapter
  • The hosts file has a series of entries to the same IP for different hosts names:

    192.168.1.100    one.local
    192.168.1.100    two.local
    
  • The Internet options has no proxy configured and no automatic configuration.

What I've done

  • Restarted IE
  • Restarted Windows
  • Ran ipconfig /flushdns
  • ping one.local returns 192.168.1.100

Results

  • Firefox works; requests to one.local return the webpage from my Windows VM's host.
  • IE returns Bing search results for one.local.
share|improve this question
up vote 4 down vote accepted

What happens if you change the domain to one.local.com?

local. is not an available TLD, so IE might be auto-redirecting anything that can't be a valid URL on the internet to whatever search provider you have configured.

share|improve this answer
    
Thank you, Darth Android. It worked. Do you know off hand if I can change that behavior with a configuration change? – mqsoh Jun 22 '11 at 22:22
1  
I was looking through that now; The company I'm at uses *.local for their internal websites, but that's configured by the DNS server and not via the hosts file. You might try turning off search suggestions from the providers in Tools -> Internet Options -> General tab -> Search section -> Settings -> Search Providers tab -> disable suggestions for each provider. – Darth Android Jun 22 '11 at 22:25
    
That was it! Thank you, Darth Android. I hate Windows, but I like you. – mqsoh Jun 22 '11 at 22:33

actually you just need to put http:// in front of it, Firefox tries this automatically for everything before going to search, IE will only do it with known TLDs. (like .com)

share|improve this answer
    
Can you expand upon this? It's not obvious how this addresses the question. – bwDraco Oct 1 '15 at 23:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.