Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have network IPP working on Ubuntu and Windows XP. On my Windows 7 instance, it refuses to acknowledge the remote server connection. Can anyone suggest how to configure this correctly?

My install steps are:

  1. Add Printer
  2. Add a Local Printer
  3. Create a New Port and "Standard TCP/IP Port"
  4. Enter hostname http://host:631/printers/Printer_Name

After that it says the printer is not detected, asks me to pick a driver, and finish up. Trying to use the device does not produce any output?

If anyone has got this work, I would really appreciate a fix.

share|improve this question
    
Why are you telling it "Local Printer" when by definition, its a Networked Printer? –  Rob Cowell Jun 23 '11 at 8:46
    
My understanding is that it is "local" in the sense that the port object is defined and allows Windows to ignore exactly where the end-point of the port is. I did try the "network" route, but it appeared to reach the same result (creating a new port reference), only with additional steps. I'll agree 100%, that who ever worked on this software did a bang-up job making it incomprehensible to a regular user. –  Casey Jun 23 '11 at 9:59

5 Answers 5

up vote 11 down vote accepted

First, make sure IPP client is turned on:

Go into the Control Panel -> Programs, select "Turn Windows features on or off"

Control Panel - Turn features on or off

In the features dialog, scroll down to "Print and Document Services". Check "Internet Printing Client"

Print Services - IPP Client

Second, my original steps were not correct. Try the following:

  1. In printer manager, click Add a printer, then Add a network, wireless or Bluetooth printer
  2. Skip detection, go Next
  3. The next dialog, "Type a printer hostname or IP address", in the middle box, where it says Hostname or IP address, use the following:

    http://HOST:631/printers/Printer_Name
    

    (If you didn't already know, you get this web address from the URL in your browser when using the CUPS webadmin)

    enter image description here

  4. Click Next, if you get an error, something is wrong, use the Back arrow (top-left) and change the URL, until Windows does not indicate it was not able to connect.

  5. Continue with the remaining prompts, and it should all work.
share|improve this answer

I use IPP for printing from Win 7 to a linux print sever. This is from the rollout sheet I use for new systems:

  • Add a printer -> Network, Wireless, or Bluetooth
  • Click STOP -> Printer I want isn't listed (mine is on a different subnet)
  • Select Shared Printer by name -> http: //host:631/printers/PrinterName
  • Wait for "Connecting to" to finish -> install driver when prompted
share|improve this answer

The following steps worked for me:

  1. Navigate to HKEY_CURRENT_USER\Printers\Settings
  2. Add a DWORD entry with name PreferredConnection and value of 0
  3. Add a new network printer as usual (New printer, network printer, printer isn't listed, etc.)
  4. Enter http://HOST:631/printers/PrinterName in the location box and use the appropriate driver from the category.

Apparently Windows 7 and Server 2008 default to RPC IPP printing. The PreferredConnection setting reverts it to HTTP.

share|improve this answer
    
This also did the trick for me for Windows 8.1 64-bit dull edition with an ipp printer shared on my Mac –  ZaphodB Dec 19 '13 at 22:58

Never use TCP/IP port as it is on 9100 or LPR. IPP use 631. So you have to add a network printer with a share name like [http://mybox:631]

share|improve this answer

I just beat my head on this for a while. ..

My corp Pc had a proxy set by netsh winhttp

I'd removed the proxy setting in IE but still by attempts to connect to my home print server running Cups from windows 7 pro failed. Once I ran "netsh winhttp reset proxy" everything worked fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.