Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

fdisk-l

/dev/sda1               1           3       24066   83  Linux
/dev/sda2              26        1300    10241437+  83  Linux
/dev/sda3            1301       60801   477941782+   5  Extended
/dev/sda5            1301        1338      305203+  82  Linux swap / Solaris
/dev/sda6            1339       60801   477636516   83  Linux

The offending partiton is sda6. Here's the output when I tried to search for an alternative superblock

sudo dumpe2fs /dev/sda6 | grep superblock
dumpe2fs 1.41.11 (14-Mar-2010)
dumpe2fs: Bad magic number in super-block while trying to open /dev/sda6
Couldn't find valid filesystem superblock.

Any chance of rescuing this partition I don't want to have reinstall debian. It's a pain since the hdd is from a NAS

sudo file -s /dev/sda6
/dev/sda6: SGI XFS filesystem data (blksz 4096, inosz 256, v2 dirs)

By the way according to apt-get I already have xfsprogs installed

share|improve this question
    
Could you add the output of sudo file -s /dev/sda6 to your question? –  Lekensteyn Jun 23 '11 at 14:38
1  
Have you already tried running xfs_repair ? –  Dan M. Jun 23 '11 at 14:47
1  
dump2efs is used for ext* filesystems. Try something like sudo mount -t xfs /dev/sda6 /mnt. –  Lekensteyn Jun 23 '11 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.