Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows XP box with Cygwin running and the SSH service. I'd like to use PuTTY to connect to it from other computers on the local network. PuTTY works fine and I actually get a relatively speedy login prompt. But anytime I do an 'ls' on the root directory ('/') it typically doesn't complete, like the command is hung. Other PuTTY sessions suffer as well, no matter what i'm doing (even just an 'ls' on my home directory might take awhile or not finish). It is like a deadlock occurred somewhere in the ssh/cygwin system.

The root directory does contain the 'cygdrive' folder which is the contents of the host computer. Could this be causing the slowdown?

share|improve this question
Do you see the same behaviour in native cygwin sessions on the Windows XP box? – EightBitTony Jun 23 '11 at 14:46
@EightBitTony Fairly certain I don't see that but i'd have to check. Which I can't do until later today. – Robb Jun 23 '11 at 14:47
I have a feeling this might be related to network shares located in the structure of cygdrive... – Robb Jun 23 '11 at 20:39
Does is the issue go away if you disable on-demand virus scanning on the XP box (assuming it's turned on) – EightBitTony Jun 23 '11 at 21:03
It is looking like a network share that was unavailable was causing the ls command to grind to a halt. – Robb Jun 24 '11 at 2:50
up vote 1 down vote accepted

Well, the issue was most certainly a network share that was unavailable. Basically the computer SSH was being hosted on talks to my wife's computer's shared directories. Well, her computer wasn't available (sleeping I believe) and it really hosed up Cygwin.

When I woke her computer up, everything started zooming again. I am confident that cygwin was unable to stat the network share and caused the slowdown.

If anyone has a better write up, I'll gladly accept that as an answer.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .