Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Have a Buffalo wifi adapter that appears to have stopped working after I ran the most recent WinXP updates. Model number is WLI-U2-G300N.

Questions, suggestions - just let me know.

share|improve this question
    
Can you list the updates? –  Tog Jun 23 '11 at 16:02
    
@Tog: Sure, though have no idea how to tell how. Do I need to post another question about getting that info? –  blunders Jun 23 '11 at 16:04
1  
If you go to the Windows Update site there is a page where you can view your previous updates. –  music2myear Jun 23 '11 at 16:27
    
+1 @music2myear: Unable to get that computer online, is there a local log file, GUI, cmd, etc. - thanks! –  blunders Jun 23 '11 at 16:47
1  
See update to post below: It may have been a driver update through Windows Updates that failed. A quick and dirty way to check your updates is to view hidden and system folders and then look at the KB folders at the top of the C:\Windows directory. These may not include driver updates, but you'll be able to tell which KB updates you got recently. –  music2myear Jun 23 '11 at 17:03

3 Answers 3

up vote 1 down vote accepted

Maybe the auto-play update? I believe Microsoft finally disabled Auto Play recently. If the adapter required a software bit to run upon insertion that would notify whichever wireless management utility it prefered, disabling Auto Play would cause problems with that.

To test this, open your Services (Start -> Run -> "services.msc" -> OK) and check to see if Wireless Zero Configuration service is running and set to automatic. If it isn't change it so it is.

Most third-party wireless devices try to run their own wireless configuration utilities, many of which offer no additional benefit to users and add complexity and slow down systems due to their higher resource usage. Using the built-in XP Wireless Utility should allow you to connect to any wireless device, configure any sort of compatible security, and it does it all without causing unnecessary complexity or slowing your computer down.

UPDATE (in response to response comment): It does not appear you're missing anything except the drivers. And +1 for not installing the apps. Is there a way to go online on another computer and download an updated copy of the drivers for the device? It's highly possible Buffalo provided an updated driver through MS update that failed to download or install properly.

MS Update is providing an increasing number of driver updates as manufacturers are finding this a reasonable and efficient method of getting updates to their users.

UPDATE 2 (in response to other comments/solutions): There are probably just three possible issues now: 1) Bad USB port. This is easily checked by seeing if the device or system react any differently when it is connected to different ports around the system, or if it is detected properly connecting to a different computer altogether. 2) Bad device. If connecting the device to a different computer has the same result, the issue is probably the device itself. 3) Messed up driver system in Windows. Running a registry cleaner (like CCleaner) or viewing all devices (including hidden/disabled) in the Device Manager and removing any no longer used may help. Also, reinstalling the most recent service pack for your OS (SP3 for XP), or running a repair install, could resolve some driver-related issues. If the device works connected to a different machine and other USB devices work OK connected to the problem machine, it is probably a windows driver issue.

share|improve this answer
1  
+1 @music2myear: Yes, I'd heard about Windows doing something with auto-play, though check Wirelesss Zero Config, and it's set to Automatic, and was started, but not seeing any wifi adapter listed under Network Connections, and Windows says "USB Device Not Recognized" when it's hooked to the computer. As fore Buffalo's software, in the past I've only installed the drivers, not their wifi management software. Anything I'm missing, or additional suggestions? –  blunders Jun 23 '11 at 16:46

hard to say. if you have the driver disk for the adapter, try reloading it before removing anything.

share|improve this answer
    
+1 @uSlacker: Good point, my bad, have a billion things going on right now. So, tried removing the drivers, which appears to have worked. Went to reinstall them, got to the point the install ask for the device to be attached, but nothing happens. Tried hooking it up one more than one USB port without success. Windows does "see" a device, but doesn't ID it as the adapter. The adapter also has a LED light that comes on, so at the very least I know that light is getting power from the USB port. Any additional suggestions? Thanks! –  blunders Jun 23 '11 at 16:16

I would first try plugging it into a different USB port, and then into a different computer to rule out the port or the drive having gone bad, which overall, is more likely, and is easier to test. That is not to say it can't be an update though, but it could just be coincidence.

share|improve this answer
    
+1 @kcotreau: Appears for some unknown reason the wifi adapter has died, since Windows can see the hardware as a device, but the drivers are unable to see the adapter on a clean WinXP-SP3 install. Do you think it's the adapter hardware if Windows sees as an unknown device, and the LED on the adapter lights up when plugged into a USB port? I've unstalled the drivers on a clean XP-SP3 install +5x and never had the drivers not be able to see the hardware when plugged in. Also, I'm able to use the USB ports for other hardware without any issues. Thanks! –  blunders Jun 23 '11 at 19:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.