Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Ubuntu Linux 11.04 64 bit. I have an intel i5 with integrated graphics and a Radeon 6950, with one monitor. I would like to run my graphics on the integrated card, and run bitcoin mining on the 6950.

I have bitcoin mining working when I use the 6950 for both display and mining. Every time I try and and use the integrated graphics instead, OpenCL doesn't recognize my 6950.

Using aticonfig --initial when using the integrated graphics for display breaks things. So I used the xorg.conf it created as a basis and tried to manually edit it. I really don't know what I'm doing, though. My last attempt is given below. The graphics ran off the integrated card, but the 6950 wasn't recognized.

Any help would be greatly appreciated!

xorg.conf:

#Section "ServerLayout"
#   Identifier     "Intel Layout"
#   Screen         "Default Screen"
#   Identifier     "aticonfig Layout"
#   Screen         "aticonfig-Screen[0]-0"
#   Screen      0  "aticonfig-Screen[0]-0" 0 0
#EndSection

Section "Module"
    Load  "glx"
EndSection

# Intel
Section "Device"
    Identifier "Intel Integrated Graphics"
    Driver     "intel"
    BusID      "PCI:0:2:0"
EndSection

Section "Monitor"
    Identifier "Default Monitor"
    Option "VendorName" "Monitor Vendor"
    Option "ModelName" "Monitor Name"
    Option "DPMS" "true"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device     "Intel Integrated Graphics"
    Monitor    "Default Monitor"
    DefaultDepth     24
EndSection

# ATI
Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
share|improve this question
    
IIRC, you need to put a "dummy plug" into one of the card's monitor outputs. Try switching the monitor's DVI cable to the ATI card and see if it's detected (if you get no output, you might have to SSH in from another PC to try this). –  Breakthrough Jun 24 '11 at 15:17
    
@Break Dummy plug doesn't work (followed instructions at bit.ly/fxmtnX). My monitor has two inputs and I tried plugging in one input to my integrated and one to my ATI. That didn't work either. –  karategeek6 Jun 24 '11 at 16:01

1 Answer 1

Try this:

aticonfig --initial --force --all

That should attempt to configure all of your GPUs, not just the first one it finds.

share|improve this answer
    
I believe I tried that when attempting to set it up and it didn't work. Gnome would never load. I could switch to a tty, but not get a graphical environment. I've actually given up on this endeavor. I bought an additional 6950 and mine at full speed on one card and on about three-quarter speed on the other. With this setup, I get about the same graphical performance I was getting with my integrated video, so it's currently good enough. Thanks for your input anyway! –  karategeek6 Jul 22 '11 at 2:52
    
Hm, I'm not sure then. There should be a way to get it to work, so that you can get full speed on both 6950s. Did you try asking in the mining section of the Bitcoin forum? –  Chris Acheson Jul 22 '11 at 5:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.