Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I find that when I type search terms into a browser, suggestions come up. Not from history but popular search terms. Fine.

But When I hold the forward arrow to put the cursor at the end of what i've typed,(not talking about using the end key), it completes what I write from popular search terms.

I want to stop this behavior.

As an example, if I type min (cursor is at end), then I push the right arrow, it completes it to say minefield. So if the cursor were in the middle and I held right arrow it'd have the same effect. I want to remove this effect.

This happens in Chrome or IE so is an issue with using Google.com I'm interested in good ways to deal with this so arrow keys function normally

share|improve this question

closed as off topic by slhck Feb 17 '13 at 10:54

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What do you want the right arrow to do instead? That might be an easier question to answer. –  ChrisF Jun 24 '11 at 12:43
1  
@ChrisF well what it normally does, move the cursor through the text. this is in the google search box, I don't want it to complete which it does based on popular search terms –  barlop Jun 24 '11 at 15:55
    
it's not just chrome, but any browser. IE too. –  barlop Jun 24 '11 at 17:16

2 Answers 2

up vote 3 down vote accepted

If I read your question correctly. The effect you are talking about is Google Instant.

To disable that feature completely do this on the Google page.

Click the little gear on the top right corner.

enter image description here

Click Search settings.

enter image description here

Check the radio button that says Do not use Google Instant.

enter image description here

Doing so will disable the feature you are talking about where pushing the right arrow autocompletes the search term.


This is what happens when Google Instant is enabled:
*Notice the little gray autocompleted phrase

enter image description here

This is with Google Instant disabled:
There is no autocompleted phrase and if you push the right arrow, it does not autocomplete it for you

enter image description here

share|improve this answer
    
click the right arrow? I don't know about you but I push the right arrow! nevertheless.. this works! –  barlop Jun 24 '11 at 18:19

I tried this on chrome 14.0.801.0 , and noticed that what you described does not happen on the unified search / addressbar. However, it does happen on the www.google.com website, but does not happen on the www.bing.com site.

I infer that this is the intended behavior of the site programmed by Google programmers.

You could create your own search page using basic HTML, save it on your computer, add a bookmark or an entry into your host file (assuming you are using windows) and use a simpler search box that does not annoy you.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.