Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Google Chrome keeps loading the second page of certain websites which is helpful on sites like Netflix so that instead of clicking on a link for page 2, I can just continue scrolling down and it'll automatically have the next page ready for me.

But on online clothing sites, it just gets backed up loading all the next pages, misplacing links and loading the next page so that it actually replaces the page I'm trying to view literally every millisecond. Considering clothing sites generally have upwards of 20 to 200 pages of clothing, this is really annoying since Chrome tries to load all of them. How do I turn off the automatic page load?

share|improve this question

Chrome doesn't do this automatically. Check your extensions and disable the one which does this. If you aren't sure, edit your question to include he list of extensions installed

share|improve this answer
I have one extension, and it is disabled. So I don't know where you get your information from. But it seems very wrong to me. Note that the question points out this only happens on certain sites. So it's obviously something scripted into those sites, and supported as standard in Chrome. – Craig Young Jun 17 '14 at 23:48

The plugin "FastestChrome" does have this feature. If you edit its options, you can set a blacklist of domains that you don't want it to pre-load next pages.

share|improve this answer

Sites that do this are most likely achieving the effect through JavaScript code. So an option you could try is to disable JavaScript for specific problematic sites.

WARNING: This may also disable other features of the sites or cause the site to behave strangely. So: Your Mileage May Vary.

To disable JavaScript for specific sites:

  • Open Settings.
  • Click Advanced Settings
  • In the Privacy Section, click Content Settings
  • In the JavaScript section, click Manage Exceptions
  • Add the sites you wish to block, and ensure you toggle the option to "Block" for those sites.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.