Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a software development box with Ubuntu Jaunty Jackalope installed. I know this version is from 2009, but it is a development box with strict requirements, so I cannot update the OS to a newer version of Ubuntu.

I cannot install new software for this version because Jaunty is no longer supported. That is, none of the Ubuntu software servers carry Jaunty anymore. For example, http://us.archive.ubuntu.com/ubuntu/dists/jaunty/ does not exist anymore. So apt-get doesn't work.

What can I do? Is there a Jaunty archive server, and how can I point apt-get to that server?

I am a Solaris/Windows user, by the way.

share|improve this question
    
Out of curiosity, why can't you upgrade? –  Simon Sheehan Jun 24 '11 at 1:24
    
Ubuntu 9.04 is the official dev environment in our group. –  stackoverflowuser2010 Jun 24 '11 at 18:06
    
Incidentally, there is also an Ubuntu Stack Exchange site: Ask Ubuntu! –  WindowsEscapist Dec 26 '12 at 22:28

2 Answers 2

up vote 6 down vote accepted

You can use the old-releases url:

http://old-releases.ubuntu.com/ubuntu/

Old-releases includes everything that isn't officially supported anymore. Just replace us.archive and security with old-releases in /etc/apt/sources.list and you should be good to go!

Note that you can also have sources from different versions of Ubuntu in you sources.list file (in fact, in the bad old days updating to the newest release meant manually replacing warty with hoary and running dist-upgrade).

So if you really need to, you can grab newer versions of packages from more recent releases without updating the whole OS.

EDIT: More detailed example. Assuming the file found here is your sources.list file, you could do something like:

$ sudo vi /etc/apt/sources.list

Inside VI

:%s/archive/old-releases/g
:%s/cl\.//g
:wq

Use us instead of cl if that's what's in your file.

Then run

$ sudo apt-get update
$ sudo apt-get upgrade

The first will update your sources based on your edited sources.list file. The second will upgrade all packages on your system to the newest version that Jaunty used before support ended (you'll be asked for confirmation first).

share|improve this answer
    
Can you provide a link to the process of adding other servers to the source.list file? Do I need to reboot after adding that line? –  stackoverflowuser2010 Jun 24 '11 at 1:46
    
Sure, here's a link to an original file. Yours probably looks something like the one here: ubuntuforums.org/archive/index.php/t-997890.html. I'll update the post with a more detailed example. –  Jacinda Jun 24 '11 at 2:01
    
No need to reboot - just run sudo apt-get update after changing the file. –  Jacinda Jun 24 '11 at 2:10
    
Thanks. Great help. –  stackoverflowuser2010 Jun 24 '11 at 18:03
    
Happy to help! Please accept the answer if you feel it is complete. –  Jacinda Jun 25 '11 at 4:43

I don't know exactly what the rationale is, but Ubuntu makes it a bit harder to install packages on versions that they no longer support. It seems that Ubuntu is nice enough to continue hosting files for the older versions, but you are on your own to discover how to access those files.

This is managed from /etc/apt/sources.list and additional files under /etc/apt/sources.list.d/. Getting to know the content of these lists is helpful for managing your installable components. Note: This is documented at man sources.list.

Let's say you have something like the following...

deb    http://archive.ubuntu.com/ubuntu/   maverick main restricted universe

Notice that this line contains a URL component. The trick is that the line is only a shorthand for the actual URL(s) that are indicated, which in this case, are...

http://archive.ubuntu.com/ubuntu/dists/maverick/main/
http://archive.ubuntu.com/ubuntu/dists/maverick/restricted/
http://archive.ubuntu.com/ubuntu/dists/maverick/universe/

The question is, are these URLs still valid? The answer is no, they no longer exist.

The solution is to identify the defunct lines in your sources.list files and modify them with the updated location -- which in this case is...

deb   http://old-releases.ubuntu.com/ubuntu/   maverick main restricted universe

Note: There are typically multiple entries in sources.list. It may be that not all of them require this type of modification -- so you have to be a bit selective, for example manually checking each entry. The short answer is: replace archive.ubuntu.com with old-releases.ubuntu.com.

After modifying this file, you need to run the following before running apt-get install:

$ sudo apt-get update
share|improve this answer
    
I have run into this on multiple occasions -- my computer is working perfectly fine, and I don't want to upgrade, but I discover that my system is "no longer supported" when I can't install some package. –  nobar Dec 26 '12 at 22:02
    
Incidentally, Wikipedia maintains a nice support timeline: en.wikipedia.org/wiki/List_of_Ubuntu_releases#Table_of_versions –  nobar Dec 26 '12 at 22:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.