Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was required to develop a Windows app UI for a fixed resolution - it doesn't matter if it makes sense or not, the customer requires it. I'm using a Windows Server 2003 VirtualBox VM as the development environment; my host machine has much higher resolution.

Is there any way to select and fix the OS resolution and stop VirtualBox changing it by any kind of scaling? I can't see the requested resolution when I open Display Properties on the guest OS.

share|improve this question

4 Answers 4

up vote 10 down vote accepted

So I tried this, and might work for you. Under the Machine menu, there is an option to auto-resize the guest OS's resolution to fit the monitor you are using. I got the resolution you did by enabling this option, manually resizing the window to get the resolution I wanted, then DISABLING auto-resize. Then, it's "stuck" there and I can resize the window, move it around, resolution doesn't change. Only problem was the taskbar. While you are doing the resize, might help to minimize it to get the exact resolution

share|improve this answer

Try installing Guest Additions. It provides lots more features to the guest OS. From there, you can leverage the resolution you want and lock the screen in that position.

share|improve this answer
    
I have Guest Additions. Problem is the resolution I need is never allowed as in the resolution selection slider in guest OS. –  Random Jun 24 '11 at 2:40
2  
What is the resolution, exactly? –  CamronBute Jun 24 '11 at 12:56
    
You may need to install the guest additions when running in safe mode. I have seen several instances where the video driver did not completely install when not in safe mode - particularly for 3D acceleration. –  Goyuix Jun 24 '11 at 19:03
    
Requested resolution is 1440x900 (HP LE1901w native) host resolution is 1920x1080 –  Random Jun 25 '11 at 10:19
3  
So I tried this, and might work for you. Under the Machine menu, there is an option to auto-resize the guest OS's resolution to fit the monitor you are using. I got the resolution you did by enabling this option, manually resizing the window to get the resolution I wanted, then DISABLING auto-resize. Then, it's "stuck" there and I can resize the window, move it around, resolution doesn't change. Only problem was the taskbar. While you are doing the resize, might help to minimize it to get the exact resolution –  CamronBute Jun 25 '11 at 15:57

I was having the same problem as described above nothing was working even the manual setting of screen resolution, I solved my problem with checking some things:

  1. In VirtualBox Manager GUI checked my OS version: I have chosen Windows 8.1 64 bit, but guest OS was 32 bit which, was the main problem
  2. Solution: new machine with win 8.1 32 bit OS and linked to an old virtual hard drive
  3. Setting machine custom resolution with VBoxManage command line

    VBoxManage.exe setextradata "[Virtual Machine Name]" CustomVideoMode1 1366x768x32
    
share|improve this answer

Even with Guest Additions installed, my remote Windows is not able to give me my wished 1920x1080 so I used this solution

vboxmanage startvm "mymachine";vboxmanage controlvm "mymachine" setvideomodehint 1920 1080 32
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.