Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i'm using an hp pavilion dv2000

i turned the wifi switch off by mistake, the LED turned orange and the wifi got disconnected.

and now when i turn the switch on, it remains orange and the wifi still isn't functional.

this happened before; i found a fix that worked searching google. it was done via terminal commands and i didn't have to download anything but i can't find the solution anymore!

wlan0 shows up when i use:

wlan0     IEEE 802.11abg  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated  Tx-Power=off
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Power Management:off

more results:

:~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

:~$ rfkill list all
1: phy0: WirelessLAN
        Soft blocked: yes
        Hard blocked: yes

:~$ sudo rfkill unblock all

:~$ rfkill list all
1: phy0: WirelessLAN
        Soft blocked: no
        Hard blocked: yes

:~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

it's still hard blocked! even though the switch is turned on; gives the same result eitherways

a direction to a page with a working solution is a much appreciated answer!

share|improve this question

migrated from stackoverflow.com Jun 24 '11 at 12:03

This question came from our site for professional and enthusiast programmers.

o snap! pro programmers r usually good with terminal commands so i hope someone might have gone through a similar problem –  ZiGi Jun 24 '11 at 11:40

2 Answers 2

Same problem here with an hp ProBook 6550b.

It worked after fresh installation of the OS in May. I am not sure but it seems that after a kernel upgrade the function of the switch broke. I tried a lot of things to get it back including upgrading to 11.10, installation of openSuSE 12.1 showed the same results.

The only way to switch it back on seems running Windows, turning it on and then rebooting to Linux. Looks like the hp tool for the special keys is broken?

share|improve this answer

I had a similar problem on my HP ProBook 6450b after I upgraded from 10.10 to 11.04. I fixed the problem on my machine by disabling the "WiFi state switch" in the laptop's BIOS. (I wouldn't guarantee that this'll work for you though but it's worth a shot. It will mean that your switch will no longer do anything.)

If that doesn't work on its own then try also re-installing your WiFi drivers. Assuming your HP uses the Broadcom BCM43xx series of WiFi chipsets like mine, you can find how to reinstall your WiFi drivers here: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

My laptop uses the Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller so I re-installed the bcmwl-kernel-source package but you may need a different package.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.