Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a WRT160NL router (192.168.1.0/24 - OpenWrt 10.04) as AP. It's:

  • WAN port: connected to the ISP
  • WLAN: working as an AP, using 64 bit WEP/SSID: "MYWORKINGSSID", channel 5, using password: "MYPASSWORDHERE"
    • Its IP Address is: 192.168.1.1

OK! It's working great!

But:

I have a TL-WR1043ND router that I want to configure as a "WDS". (My purpose is to extend the wireless range of the original WRT160NL.)

Here is how I configure the TL-WR1043ND:

enter image description here

  1. I enable WDS bridging.
  2. In the "Survey" I select my already working network.
  3. I set up the encryption (exact same like the already working one)
  4. I choose channel 5
  5. I type the SSID
  6. I disable the DHCP server on it.

After I reboot the router and connect to this router (TL-WR1043ND) over wireless I'm trying to ping google.com.

From the ping I see that I can reach this router. That's OK, but it seems like this router can't connect to the original one, the WRT160NL (so I don't get a ping reply from Google). The encryption settings/password is good; I checked it many-many-many times.

What could be the problem?

I'm thinking it could be a routing problem, but what should I add to the "Static Routing" menu?

I tried to change the IP address of the TL-WR1043ND to: 192.168.1.2. So if this a routing issue then I should add a static routing rule that says:

If destination is any then forward the packet to 192.168.1.1.

PS: I updated the firmware to the latest version. It's still the same.

PS 2: The hardware version of the TL-WR1043ND is 1.8.

PS 3: Could that be the problem that I use different routers? (If I would buy.. another TL-WR1043ND and use it instead of the WRT160NL, and with normal firmware, not OpenWrt, would it then work? The "WDS" is different on different routers.)

PS 4: I will try to check the router logs tonight - and paste it here!

share|improve this question
    
do I have to do anything on AP side? –  LanceBaynes Jun 26 '11 at 9:45

1 Answer 1

It looks like you've configured your TP-Link TL-WR1043ND correctly. But for traditional WDS, you have to configure both intended ends of the WDS link to bridge packets to each other over WDS. So when you ask if you have to do anything on the "AP" side, I assume you mean the Linksys WRT160NL running OpenWrt. Yes, you have to configure OpenWrt to know to do WDS bridging to the TP-Link TL-WR1043ND.

Unfortunately WDS is notoriously under-specified and thus differently implemented between different Wi-Fi chipsets, and thus not always compatible, even with the heroic efforts of aftermarket firmware distros.

The backstory on WDS is that the IEEE 802.11 standard provides a frame addressing format to allow devices to act as wireless bridges between two wired Ethernets. This is known as a Wireless Distribution System or WDS. Unfortunately the standard doesn't provide a link negotiation or authentication mechanism or even a proper link up/down detection/notification system for WDS links. It's like the IEEE specified a few of the basic building blocks, but didn't really specify a full protocol for making WDS work and interoperate.

For best results

Because of the lack of a negotiation mechanism, both ends have to be manually, statically configured. Each must know the MAC addresses of its WDS peers, and they must all be preconfigured to use the same channel and encryption. They can't even negotiate supported data rates, so you have to ensure that they are configured for the same (or a reasonably overlapping) set of data rates. As 802.11 grows more complex with subsequent addenda, there are more and more settings that may have to be manually configured on each end for best results. WME (QoS)? 802.11n HT 20/40 mode? Greenfield mode? ...the list grows every year.

Overall, the only way to make WDS work reliably is to buy two identical or at least same-vendor boxes that support it in their factory firmware, and set it up according to that vendor's instructions, and call their tech support if it doesn't work. Otherwise you'll just get a lot of finger-pointing.

share|improve this answer
    
"I have a WRT160NL router (192.168.1.0/24 - OpenWrt 10.04) as AP." So my WRT160NL has OpenWrt 10.04 on it :P So you say it would be easier to buy two e.g.: TL-WR1043ND router? And use them in WDS mode? (because of the difference in WDS? WRT160NL vs. TL-WR1043ND?) –  LanceBaynes Jun 27 '11 at 7:24
    
@LanceBaynes Oops you're right I overlooked that. I've updated my Answer. See especially the last paragraph. –  Spiff Jun 27 '11 at 23:05
    
The TL-WR 1043ND has Atheros AR9132 and the WRT160NL has an Atheros AR9130. :( So I will have to buy another TL-WR1043ND... –  LanceBaynes Jun 28 '11 at 5:01
    
@LanceBaynes if I were you I'd try it first. Did you try configuring OpenWrt on the Linksys for WDS? If that didn't work, I might try putting OpenWrt on the TP-Link box as well, and see if that works. But that's because I'm cheap and would rather experiment with firmware changes than buy a different box. –  Spiff Jun 28 '11 at 7:54
    
forum.openwrt.org/viewtopic.php?pid=95217#p95217 - so the problem is with the WRT160NL - it doesn't really supports WDS mode... :\ –  LanceBaynes Jun 28 '11 at 8:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.