Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to build Firefox from source code under my Macbook pro. I believe I follow all direction on their pages, yet I still stuck on building it up.

I installed all requirement (mercurial libidl autoconf213 yasm) via Macport and its under /opt/local/. When I tried to run make -f, it gave me error. It seems like it couldn't locate glib 2.0 and libidl. The actual output was like this:

checking for libIDL-2.0 >= 0.8.0 glib-2.0 gobject-2.0... checking for glib-config... no
checking for GLIB - version >= 1.2.0... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
checking for libIDL-config... no
checking for libIDL - version >= 0.6.3... no
*** The libIDL-config script installed by libIDL could not be found
*** If libIDL was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the LIBIDL_CONFIG environment variable to the
*** full path to libIDL-config.
checking for libIDL-2.0 >= 0.8.0... Package libIDL-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libIDL-2.0.pc' to the PKG_CONFIG_PATH   environment variable No package 'libIDL-2.0' found
configure: error: Library requirements (libIDL-2.0 >= 0.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

I Googled for a couple of hours for this one, but still couldn't find the solution for it. Any ideas?

share|improve this question
up vote 1 down vote accepted

In case anyone still has this problem, I needed to install the glib1 port to get Firefox to build; the glib port installed glib 2.3 which doesn't work.

share|improve this answer

Try installing glib via MacPorts.

share|improve this answer
I did.. and it still gives me error – REALFREE Jun 26 '11 at 7:25
@REALFREE: The same error, or another one? – Tom Wijsman Mar 5 '12 at 20:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.