Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's the setup: I have an older piece of remote monitoring equipment, known as a Badger. The GUI control software that runs on Windows is a Java app, the CD has a date of 2003 but I think the software is much older. The setup.exe does not run on my AMD64 Windows 7 installation, I receive a 32 bit/ 64 Bit error, I suspect it might be a 16 Bit app (it's surely ugly enough).

Anyway, I tried to solve this with an XP VM Guest in VirtualBox on the AMD64 Windows 7 host. The setup.exe runs fine but when I try to launch the Java application I get an immediate Windows error:

java.exe has encountered a problem and needs to close.

If I click here to see what data this error report contains, I get:

AppName: java.exe AppVer: 0.0.0.0
ModName: javai.dll ModVer: 0.0.0.0
Offset: 0009b4e

When I view technical information about the error report, there is the usual binhex gibberish but some of the text complains about being out of memory, bad superclass, bad index, class storage allocation error, among others.

Behind the error is the CMD window with:

Symantec Java! JustInTime Compiler Version 3.00.029(i) for JDK 1.1.x, Copyright 1996-98 Symantec Corporation

Later, at home on my iMac which also had an XP VM Guest in VirtualBox available, I installed the software and successfully launched it. I then exported the VM, imported it into my Windows 7 AMD64 host and ran right into the same error as described above.

Obviously, the Hosts are very different from each other but I'm wondering what specifically is the cause for this behavior, where it works on the Mac host but not on the AMD/Windows host?

share|improve this question
    
Just to update, running Vista (gag) on the wife's laptop with an Intel Centrino processor also works with VirtualBox and the XP VM. –  baraboom Jun 27 '11 at 17:09
    
You don't mention the VirtualBox version(s). Could your Mac and PC be running different versions of VB? –  CarlF Jun 27 '11 at 17:19
    
@CarlF, I wish it were that simple but they are all running version 4.0.8 (the latest, I believe). –  baraboom Jun 27 '11 at 17:23
    
Are the two VM Xp installs the same? Virtualbox warned me about something to do with the bit-ness of Windows on Mac. Windows on Windows only lets you go one step down, so a 64 XP can use wow to run 32bit, and a 32bit XP can use wow to run a 16bit program –  tobylane Aug 21 '11 at 20:54
add comment

4 Answers

Some CPU differences are visible to guests in virtual machines like VMware, Virtual PC (current version) and VirtualBox which use native code execution.

Try:

  • disabling hardware virtualization. Machine -> Settings -> System -> Acceletation; uncheck Enable VT-x/AMD-V
  • using a different virtual machine program, maybe an actual emulator such as Bochs or QEMU (the latter would have to be appropriately configured as it can use native execution as well as emulation).
  • running it on a different PC
share|improve this answer
add comment

I actually worked on the software that you're referring. Things we've done in the past to get around strange java/OS issues was to change the GUI shortcut target to use your installed Java version rather than the Java version we sandboxed on the CD. Try changing that and then running the shortcut to see if that helps.

Good Luck!

share|improve this answer
add comment

I can't answer your specific question about what is different between the hosts but you might be able to get your Badger GUI control software to work by using a more modern Java Virtual Machine.

Try installing the latest JVM in your Windows 7 AMD64 host - Windows XP guest VM, and using that to run the program.

Download here: http://www.java.com/en/download/manual.jsp

share|improve this answer
    
Yea I've considered posting a second question on actually fixing the issue - I've looked into downloading newer java software but not sure how to go about marrying the badger software to the newer java.exe... my Shortcut commandline now reads: "C:\AIbadger DAD\JAVA\Bin\java.exe" -classpath .\userinterface.jar;.\klg.jar;.\symbeans.jar;..\java\lib\classes.zip FrameMain. As you can see, it ships with the old java.exe. If you want to help and earn some rep, I'll post the question - let me know. :) –  baraboom Jun 27 '11 at 17:13
add comment

I wonder if the problem you are having is related to the Windows 7 firewall blocking the software from connecting to the Badger equipment and the Java application rather than handling that exception gracefully just ends. I am not familiar with the Badger equipment but that fact that you got the VM working on the iMac (which by default does not enable the firewall) but the same VM failed on the Windows 7 box (which by default does enable the firewall) leads me to believe that may be the problem. I would suggest using the Service Manager application on Windows 7 to temporarily stop the firewall service, and run your test again to see if it is successful this time. If it is then you will have to check the Badger documentation to see what ports it uses and allow those through your firewall. If it is using the SNMP protocol then you would need UDP/161 and UPD/162 open.

share|improve this answer
    
I appreciate the answer but there is no firewall active on the host (or the VM). Good thought re: the un-handled exception, I will try thinking some about that possibility although I'm still leaning towards something more low level, either in the host OS or the hardware creating some weird conflict at the virtualization layer. –  baraboom Jun 28 '11 at 1:24
    
Thinking along similar lines as the firewall, do you have any active Anti-Virus/Spyware software active on the Windows 7 machine. I have seen McAfee Host Intrusion software silently kill SMTP request for example. –  tchester Jun 28 '11 at 1:36
    
There is AVG running, I will try disabling that tomorrow just to see. Also, I've got an outbound firewall (lil' snitch) running on my mac and the control software does not initiate any network activity upon successful launch in the xp VM. –  baraboom Jun 28 '11 at 2:09
    
Disabling AVG has no effect on the issue. When the java.exe is launched, it crashes immediately. Unless of course I'm on the Vista/Centrino laptop or my MacOSX/Intel iMac. –  baraboom Jun 28 '11 at 12:18
    
Hmm, I'm still leaning towards a hardware issue related to the VM. If you view the Device Manager of your XP guest are any devices such as the network adapters not working. In addition are you successfully able to view internet or ping devices from the XP VM outside the Windows 7 host. –  tchester Jun 28 '11 at 20:48
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.