Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using gpg-agent to manage my github ssh key. I generate my (private) ssh key via openpgpg2ssh from my private gpg key. Unfortunately, although my private gpg key is not password protected, gpg-agent asks me for a password (via a nice X dialog) before I ssh/git to github. Entering nothing works fine, and I can connect to github.

~$ eval "$(gpg-agent --enable-ssh-support --daemon)"
~$ gpg2 --export-secret-keys | openpgp2ssh | ssh-add /dev/stdin
Identity added: /dev/stdin (/dev/stdin)
~$ ssh [email protected]
PTY allocation request failed on channel 0
Hi xxx! You've successfully authenticated, but GitHub does not provide shell access. Connection to github.com closed.

Is there any way I can disable this needless dialog? Other than that, why do I get a "PTY allocation request failed on channel 0"?

I am running GNU/Linux; Debian 6; x86_64

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.