Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently installed Windows Home Server 2011. For those that don't know, it runs on Windows Server 2008 R2 SP1. Unfortunately, I cannot remote desktop to box by machine name I gave it. I set the computer name to during install to ATLAS. I have confirmed it is called ATLAS on the machine. No idea how, but even after I run ipconfig /flushdns and then run nslookup, I get the following:

nslookup atlas 127.0.0.1

nslookup server 192.168.1.68 (correct IP)

Methods:
IPv6: Works
IPv4: Works
"ATLAS" machine name: No
"Server" machine name: Works

Any ideas how I can fix this or how it keeps setting the machine name to "server" ?

Update: Here are the results of two different ping tests. Notice that when I ping ATLAS, it doesn't have a DNS suffix.

ping atlas Pinging ATLAS [192.168.1.68] with 32 bytes of data:

nslookup server Pinging server.gateway.2wire.net [192.168.1.68] with 32 bytes of data:

share|improve this question

migrated from stackoverflow.com Jun 25 '11 at 2:07

This question came from our site for professional and enthusiast programmers.

    
nslookup works via DNS. If the machine has a dynamically allocated IP address you might want to refresh/renew it to let it automatically register itself in DNS (or let the DHCP server do it, if the DHCP server is directed to register all DHCP leases into DNS). –  ta.speot.is Jun 25 '11 at 3:27

2 Answers 2

Are you sure that the firewall settings are configured correctly? Most probably a firewall issue.

share|improve this answer
    
Which firewall? My laptop or the server? The router? What kind of settings would I be looking for? –  IrishBoiler Jun 25 '11 at 0:14
    
Have you checked if Network discovery is set to ON on both machines? You can check it at network & sharing center by clicking the network connection icon on the system tray (just in case you don't know). Also check that the network is not set to "public" network as it will also turn off discovery. –  can poyrazoğlu Jun 25 '11 at 0:19
    
Both are set to Network discovery to ON. I can pull up the network map in Network & Sharing center on my laptop and it correctly calls the machine ATLAS. ATLAS even joined the homegroup –  IrishBoiler Jun 25 '11 at 0:25
    
Just to be sure, you can RD by IP address, right? –  can poyrazoğlu Jun 25 '11 at 0:33
    
Correct, using either the IPv4 or v6, I can get there just fine –  IrishBoiler Jun 25 '11 at 0:36
up vote 1 down vote accepted

In the end, I gave up and just added it to the hosts file on my laptop. While it works, I was hoping for a more universal solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.