Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Now I have looked at a few sites on the internet and everyone says these are the steps.

  1. Open 'Internet Options'.
  2. Click on the 'Security' tab.
  3. Select the 'Internet' zone
  4. click on the 'Custom level...' button.
  5. Scroll down till you find the 'Scripting' section.
  6. Under 'Active scripting', select 'Disable'.

I repeated steps 4 - 6 to disable for 'Local intranet' and 'Trusted sites' zones as well. (The 'Restricted sites' zone has already set 'Active scripting' as disabled).

7. Close and open Internet Explorer 9 to restart it.

However, I see that Javascript still executes. I run the following bit of code to verify. The backround always turns red.

<html>
<body style="background-color:white">
<p>Paragraph 1</p>
<script type="text/javascript">
    document.bgColor = "RED";
</script>       
</body>
</html>

On Firefox and Chrome, I can easily turn off Javascript and the background is always white.

N.B. - I execute the htm file with javascript by double clicking it. It isn't being served from a web server.

share|improve this question
    
What did Javascript ever do to you? –  tjameson Jun 25 '11 at 4:53
    
@tjameson At school I wasn't the smartest; everyone knew javascript and I didn't. Now I shall take me revenge. But seriously, I need this to test some HTML and CSS rendering of already written javascript pages. And instead of weeding out the javascript, I'd rather disable it's execution. –  Thomas Jun 25 '11 at 4:58
    
Ah, ok. I'm sorry about your past, I'm sure Javascript will forgive you. He has a pretty short memory. –  tjameson Jun 25 '11 at 5:00
    
I'm experiencing exactly the same thing. Followed all the steps, testing Javascript with a simple inline <script> that calls a simple alert(). The alert keeps popping up, regardless. WUWT? –  Tom Auger Sep 13 '11 at 15:06

1 Answer 1

Make sure you clear your cache just to be sure. And what's worse, there's a little checkbox in the Clear Cache dialog box that PREVENTS cached data on your preferred sites from being cleared. As a developer you definitely want this turned OFF, since based on Microsoft's algorithm, your preferred sites will be the sites that you're currently working on!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.