Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've a shiny new Ubuntu 11.04 installation. In addition to the system disk, I've added a 2TB drive (/dev/sda) for data.

System monitor reports 1419.5 GiB "Free" and 1326.3 "Available".

Reading around the web leads me to believe that the system is reserving this ~6% as "root reserved space"

Well, I don't think I want "root reserved space" on a pure data disk, so I tried the oft suggested:

tune2fs -m 0 /dev/sda

on the drive only to receive:

tune2fs 1.41.14 (22-Dec-2010)
tune2fs: Bad magic number in super-block while trying to open /dev/sda
Couldn't find valid filesystem superblock

The filesystem is ext4 and the partitioning is somehow "GUID" (<- Not familiar with this one)

The mighty Google was little help. Can anyone out there tell me how to eliminate the "reserved space" on this new data drive?


share|improve this question
up vote 3 down vote accepted

You should be accessing /dev/sda1, not /dev/sda. You are attempting to access the entire disk, not a partition. A filesystem should always be on a partition, not on the whole disk. If the filesystem is on the whole disk, try repartitioning the disk using fdisk or a similar utility so that one partition /dev/sda1 exists, then format the partition to ext4.

share|improve this answer
Perfect! That worked. Thank you! – JS. Jun 30 '11 at 2:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.