Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using IE9, I've tried installing Google Chrome on Windows 7 from this url http://www.google.com/chrome/eula.html?hl=en-GB&platform=win

But get the following error (apologies for uncouthly dumping this nonsense...)

Any ideas dearly appreciated!

PLATFORM VERSION INFO
    Windows             : 6.1.7601.65536 (Win32NT)
    Common Language Runtime     : 4.0.30319.235
    System.Deployment.dll       : 4.0.30319.1 (RTMRel.030319-0100)
    clr.dll             : 4.0.30319.235 (RTMGDR.030319-2300)
    dfdll.dll           : 4.0.30319.1 (RTMRel.030319-0100)
    dfshim.dll          : 4.0.31106.0 (Main.031106-0000)

SOURCES
    Deployment url          : _http://dl.google.com/update2/1.3.21.57/GoogleInstaller_en-GB.application?appguid%3D%7B8A69D345-D564-463C-AFF1-A69D9E530F96%7D%26iid%3D%7B26C55C3A-B26A-0484-FEDD-78443D269DA1%7D%26lang%3Den-GB%26browser%3D2%26usagestats%3D0%26appname%3DGoogle%2520Chrome%26needsadmin%3Dfalse%26installdataindex%3Ddefaultbrowser

ERROR SUMMARY
    Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of _http://dl.google.com/update2/1.3.21.57/GoogleInstaller_en-GB.application?appguid%3D%7B8A69D345-D564-463C-AFF1-A69D9E530F96%7D%26iid%3D%7B26C55C3A-B26A-0484-FEDD-78443D269DA1%7D%26lang%3Den-GB%26browser%3D2%26usagestats%3D0%26appname%3DGoogle%2520Chrome%26needsadmin%3Dfalse%26installdataindex%3Ddefaultbrowser resulted in exception. Following failure messages were detected:
        + The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

COMPONENT STORE TRANSACTION FAILURE SUMMARY
    No transaction error was detected.

WARNINGS
    There were no warnings during this operation.

OPERATION PROGRESS STATUS
    * [25/06/2011 11:41:04] : Activation of _http://dl.google.com/update2/1.3.21.57/GoogleInstaller_en-GB.application?appguid%3D%7B8A69D345-D564-463C-AFF1-A69D9E530F96%7D%26iid%3D%7B26C55C3A-B26A-0484-FEDD-78443D269DA1%7D%26lang%3Den-GB%26browser%3D2%26usagestats%3D0%26appname%3DGoogle%2520Chrome%26needsadmin%3Dfalse%26installdataindex%3Ddefaultbrowser has started.

ERROR DETAILS
    Following errors were detected during this operation.
    * [25/06/2011 11:41:04] System.IO.FileNotFoundException
        - The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
        - Source: System.Deployment
        - Stack trace:
            at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore(UInt32 Flags, IntPtr hToken, Guid& riid)
            at System.Deployment.Application.ComponentStore..ctor(ComponentStoreType storeType, SubscriptionStore subStore)
            at System.Deployment.Application.SubscriptionStore..ctor(String deployPath, String tempPath, ComponentStoreType storeType)
            at System.Deployment.Application.SubscriptionStore.get_CurrentUser()
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS
    No transaction information is available.
share|improve this question
    
32 bit or 64 bit Windows 7? – ChrisF Jun 25 '11 at 11:16
    
Try right clicking on the standalone installer and clicking "Run as administrator". – Bob Mar 7 '12 at 16:03
    
Important line here is "The system cannot find the file specified" check to make sure you have permissions to install programs and make sure that your disk is clean with a chkdsk. – Jeff F. Dec 19 '12 at 14:33

You could use the Portable version of Chrome http://portableapps.com/apps/internet/google_chrome_portable

share|improve this answer

Alternate way to install Chrome

http://www.google.com/support/installer/bin/answer.py?answer=126299&&hl=en

share|improve this answer
    
Tried that alternative installer but arrive at same error message. It's almost as though Internet Explorer 9 is prohibiting the deed. – purir Jun 25 '11 at 22:34
    
Do an IE reset, Internet Options>Advanced Tab – Moab Jun 25 '11 at 22:43
2  
@purir, But IE has nothing to do with it if you use the standalone installer. – Synetech Jun 30 '11 at 2:09

Google Chrome uses ClickOnce to install. It is reportedly a permission error, that can be fixed by deleting %userprofile%\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat - though with another (administrator) account, since it is locked if the user is logged in. I would personally recommend you rename it to something, e.g. UsrClass.dat.bak, so if something goes wrong or it doesn't work you can restore it.

See for more info: http://social.msdn.microsoft.com/forums/en-US/winformssetup/thread/ef690458-22bc-4d72-a36c-773c1cc6fa15/

Possible alternative solutions: http://stackoverflow.com/questions/7779043/filenotfoundexception-during-clickonce-install-missing-hkcu-software-classes-so

share|improve this answer

You need to save the file and then open outside IE

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .