Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a new SSD (OCZ Vertex 2 120GB) as a replacement for my laptop HDD . I created a System Image on an external drive using the Win 7 backup and restore tool and then restored this image to the SSD using the Win 7 disk.

AHCI is enabled in Win 7 and the BIOS, but it seems that windows is not detecting the disk as an SSD because, in the defragger, the disk is still available for defragging. Prefetch and Superfetch were also still enabled.

I have manually disabled scheduled defragging, prefetch and superfetch. I have also checked that TRIM is enabled using:

fsutil behavior query DisableDeleteNotify

and the result is '0' (it is).

Performance seems ok, but not quite as fast as I expected. Was restoring from a win7 generated system image a mistake? Am I getting optimal SSD performance?

share|improve this question
add comment

2 Answers

The SSD will still be available for defragging manually if you really want to. What Windows 7 should do, is remove it from the defrag schedule (so it won't get defragged automatically)

So, if you run the defragger (eg %windir%\system32\dfrgui.exe) and click on Configure Schedule and Select disks, does the SSD drive appear there? (It shouldn't).

Re prefetch and superfetch.

How do you know they are enabled?

As I understand it, defragging an SSD can shorten its lifespan (and so you don't really want to do it regardless of the speed of your SSD) whereas prefetch and superfetch are normally disabled on fast SSD's because they don't provide any benefit on fast SSD's and not because because they cause problems.

From the Engineering Windows 7 team (see http://blogs.msdn.com/b/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx )

Be default, Windows 7 will disable Superfetch, ReadyBoost, as well as boot and application launch prefetching on SSDs with good random read, random write and flush performance.

The implication is that it will enable them if it thinks it helps.

What sort of figures do you get if you run HDTune (http://www.hdtune.com) ?

Was restoring from a win7 generated system image a mistake? Am I getting optimal SSD performance?

Can't answer that question, but I can point you to Paragon's blog Misaligned partitions are a problem for SSD's (Note, they sell a product to re-align your partitions)

See also here

I must confess, I am still running with a mis-aligned partition. I keep telling myself that one of these days I will try Paragon's program to see if it makes a difference, but have not got round to that yet.

share|improve this answer
    
Thanks for your detailed response. –  steviey Jun 25 '11 at 18:24
    
The SSD isn't available in the 'Select Disks' dialog of the defrag scheduler (good news). I checked the prefetch and superfetch in this registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters. Both were set to '3' and I changed them to '0' (I'll probably reset them to 3 now). The output of HDTune is :HD Tune: OCZ-VERTEX2 Benchmark Transfer Rate Minimum : 132.6 MB/sec Transfer Rate Maximum : 203.9 MB/sec Transfer Rate Average : 158.3 MB/sec Access Time : 0.2 ms Burst Rate : 148.6 MB/sec CPU Usage : 3.7% –  steviey Jun 25 '11 at 18:25
    
Bear in mind that my laptop only supports SATA I. –  steviey Jun 25 '11 at 18:31
add comment

The utilities you mentioned were most likely enabled because they were enabled when you did the system image, and the restore of course put the system back as it was.

With your ...only supports SATA I comment, that is DEFINITELY why you're not noticing a difference with your speed. A good SSD can completely saturate a SATA II connection, so you won't ever be able to get top performance from that or anything less.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.