Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I forgot to set a make --prefix and I think it wrote to /usr/local/ by default and now I'm having all kinds of errors. I'm on ubuntu natty, what's the easiest way to resurrect glibc. I've tried to uninstall/reinstall using apt-get, and dkpg-reconfigure on libglibc2.0-dev but didn't work. I tried to download glibc from source and it gave error "sorry, unimplemented: inlining failed in call to ‘syslog’: function body not available". Apparently I have to rebuild gcc pass it kernel headers and do all sorts of devilry the least of which I understand.

I don't really want to have to reinstall everything if possible any help would be appreciated.

edit: Looks like it overwrote during install /usr/local//lib/libm.a /usr/local//lib/libc.a

$ ldd /bin/ls
linux-vdso.so.1 =>  (0x00007fff453ff000)
libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007fdcd202f000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fdcd1e27000)
libacl.so.1 => /lib/x86_64-linux-gnu/libacl.so.1 (0x00007fdcd1c1e000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fdcd188a000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fdcd1686000)
/lib64/ld-linux-x86-64.so.2 (0x00007fdcd2271000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fdcd1467000)
libattr.so.1 => /lib/x86_64-linux-gnu/libattr.so.1 (0x00007fdcd1262000)

According to this site for it to work I have to make some modifications for things not to break when I am compiling, but it would be nice if I could somehow undo the mess I made. I lack a fundamental understanding of how a lot of this works.

share|improve this question

migrated from stackoverflow.com Jun 25 '11 at 18:54

This question came from our site for professional and enthusiast programmers.

1  
Try ldd /bin/ls first to see if that program uses the right libc. –  larsmans Jun 25 '11 at 18:26
2  
You could try booting with the install cd in recovery mode, but I've only ever done that on RHEL. –  Corey Henderson Jun 25 '11 at 18:28
1  
ls seems to be using the libraries from the right places, i.e. not from /usr/local/lib, where these libraries shouldn't be doing any harm anyway. –  larsmans Jun 25 '11 at 18:38
    
I've tried several different sources I had already compiled before that worked fine, they give errors like "undefined reference to X" and "Y.h: present but cannot be compiled check for missing prerequisite headers?" I'll try dpkg-reconfigure -all and if that fails I'll try recovery mode. Thanks guys –  ForeverConfused Jun 25 '11 at 18:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.