Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This behavior continues to perplex me. My MBP, running 10.6.7, stops responding to all Apple-based software. Whatever software I have open remains open (Terminal, iTunes, Safari), but if I try to use the F-shortcuts or launch any OSX-based software not already open (System Preferences for example) it just bounces in the dock then never launches.

I also cannot reboot without hard rebooting.

I left terminal open, so I see the following in /var/log/system.log

Jun 25 19:39:02 mjb-2 com.apple.ReportCrash.Root[59432]: 2011-06-25 19:39:02.585 ReportCrash[59432:7f1f] Saved crash report for CoreServicesUIAgent[59576] version ??? (???) to /Library/Logs/DiagnosticReports/CoreServicesUIAgent_2011-06-25-193902_localhost.crash
Jun 25 19:39:02 mjb-2 com.apple.ReportCrash.Root[59432]: 2011-06-25 19:39:02.586 ReportCrash[59432:b10f] Saved crash report for quicklookd[59571] version ??? (???) to /Library/Logs/DiagnosticReports/quicklookd_2011-06-25-193902_localhost.crash
share|improve this question
    
Have you tried repairing the disk via the Mac OS X install DVD? –  user78429 Jun 26 '11 at 0:55
    
Yes - I've repaired / corrected permissions from DVD. This still occurs. Note: it only happens when I put the system to sleep multiple times... that's part of the interesting behavior. –  mjb Jun 26 '11 at 2:47

1 Answer 1

up vote 2 down vote accepted

Since you're handy with the Terminal, try using sudo syslog to see all messages in the syslog database, regardless of what text log they may or may not have gotten written to.

Also look in /Library/Logs/DiagnosticReports for crash, hang, and spin reports.

The sample and spindump commands are your friends as well, as is top.

Gather some of that information and paste it in here (or link from here to pastebin or a github gist) and give us a crack at figuring it out for you.

(Don't post the whole output of sudo syslog -- it likely goes back a long, long time. Just do the stuff from around the last time it happened.)

Update: If the timestamps on those crash logs you mentioned happen to correspond to when the problem is happening, don't forget to post those as well.

Also, here are two other SuperUser Questions with similar symptoms. Maybe look these over and see if you're hitting the same things (you don't happen to be running Mozy or "Hands Off!", do you?), or if you can glean troubleshooting tips from these.

Some Mac applications crash frequently, with "__THE_SYSTEM_HAS_NO_PORT_SETS_AVAILABLE__" in backtrace

Getting console message: ipc_kmsg_copyout_header: can't grow user ipc space. Any Mac OS X kernel gurus in here?

share|improve this answer
    
I should have read the parenthesis first... terminal went nuts with syslog output :) More info to come! –  mjb Jun 26 '11 at 2:44
    
ok, spindump is the coolest command I've learned in a while. Voting up for that beautiful output. –  mjb Jun 26 '11 at 2:53
    
It happened again! I ran spindump and syslog and then looked with top and found a pid and killed it. Results? System shutdown. I saved files to /tmp too so I've got nothing. Balls balls balls. More to come... –  mjb Jul 12 '11 at 4:22
    
@mjb It would be interesting to know the name (not just pid) of the process you killed. For example launchd and WindowServer are probably not the best processes to arbitrarily kill... :-) –  Spiff Jul 12 '11 at 16:52
    
It was #38 - I think WindowServer. The premise was that it could be some sort of virus-bound service, but in actually it was a lesson on OSX system architecture :) –  mjb Jul 12 '11 at 18:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.