Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was using win-7. I tried to install RHEL 6 today. [dual boot]

/ = 40000 MB and /boot = 1000 MB

The installation completed successfully.

The problem is that it is not showing the graphical mode. Only the terminal mode is available. I tried

chvt 1-7

but I am unable to go to the graphical mode. It is not appearing. What should I do?

System config:

MSI CR420 Laptop. Intel core i3-350M

Edited after following user76871's answer:

There is no Xorg.0.log file in /var/log/, There is no xdm in /etc/init.d/, there is no kdm also.

I tried startx that also didn't work. I tried system-config-display but the display is not available at system-config-

share|improve this question

migrated from Jun 26 '11 at 8:59

This question came from our site for professional and enthusiast programmers.

Reason for close vote? – Chankey Pathak Jun 26 '11 at 8:52
This question is on the wrong forum, it should probably be on SU instead. And, if you wat someone to help you, you need to add more information to your question. As it is now, there is not enough info to be able to help you. – uvesten Jun 26 '11 at 8:54
probably it is not a programming related question (i did not vote) – phoxis Jun 26 '11 at 8:54
OK and the reason for down-vote? Same? :P – Chankey Pathak Jun 26 '11 at 8:54
up vote 1 down vote accepted

The problem has been solved. Actually at the installation time it asks whether you want to install a basic server or want to include desktop and some other features. By default the BASIC SERVER option is marked and hence it doesn't include the graphical interface. I reinstalled with the Desktop option and it worked fine.

share|improve this answer

Look in /var/log/Xorg.0.log and hit / and type \(EE then hit Enter, then to find more errors hit /-Enter.

Do /etc/init.d/xdm OR kdm restart to try to launch X once you fix the error; you may have to google for them.

(sidenote: Sometimes this may indicate that you're missing appropriate graphics drivers, which sometimes happens when they get out of sync with the kernel while upgrading and using proprietary drivers... but this would be uncommon when installing.)

login as root and try init 5 (command for graphical run level) or in vi /etc/inittab check default run level is 5 or not

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .