Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I disable Ctrl + Alt + F1 (for F1 through F12 ) buttons?

How can I configure Debian("Squeeze") so that nothing happens when the user presses those keys?

I'm using Gnome as the default desktop.

share|improve this question
add comment

1 Answer 1

up vote 7 down vote accepted

This requires some manual X11 server configuration. Look in /etc/X11/xorg.conf; if it doesn't exist, you'll need to create it with the following contents:

Section "ServerFlags"
  Option "DontVTSwitch" "on"
EndSection

If it does exist, look for a Section "ServerFlags" and add the Option line above to it; if there isn't one, append the above lines to the file.

share|improve this answer
1  
What can I do if, for some reason, I want only to disable Ctrl + Alt + F11? –  Radu Rădeanu May 1 '13 at 9:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.