Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 monitors:

  • 24" LCD connected via DVI(primary)
  • 19" LCD connected via VGA(secondary)

Everytime Fedora starts the second display is always set to clone the first one and they both run at 1280x1024 and I always have to disable the 19" monitor, in order for the bigger one to run at 1920x1080.

I want to set them up so that my secondary monitor extends the primary one.The problem is that no matter what kind of configuration I choose it has no effect.My secondary monitor remains disabled.

I've tried using both the Display manager from KDE and the ATI Control Panel and the behaviour is always the same.The moment I click apply, the screen flickers and nothing changes.

I've succesfully used the extended setup in Fedora15 with Gnome3.

I have a RadeonHD 4300 series videocard and I'm using the drivers downloaded from the AMD site.

This is the output of xrandr -q :

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 1920 x 1920
VGA-0 connected (normal left inverted right x axis y axis)
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     66.0     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     59.9  
   720x400        70.1  
DVI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+   60.0  
   1680x1050      59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1280x720       60.0  
   1152x720       60.0  
   1024x768       75.0     60.0  
   832x624        74.6  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
   720x400        70.1  

Later edit:

The problem seems to come from the ATI drivers.I managed to set up the monitors like I wanted after I uninstalled the drivers. Unfortunately I'm working on an OpenCL project so I had to reinstall them.The moment I did that, all my previous settings were forgotten and I was back to square one.

share|improve this question

For multiple monitors in KDE, you need to replace xrandr with kscreen. Try to install kscreen or kscreen-frameworks.

To set it up in Plasma 4

  • Disable the old screen management:

    qdbus org.kde.kded /kded org.kde.kded.unloadModule randrmonitor
    qdbus org.kde.kded /kded org.kde.kded.setModuleAutoloading randrmonitor false
  • Load KScreen KDED module:

    qdbus org.kde.kded /kded org.kde.kded.loadModule kscreen

Alternatively for Plasma 5, replace in the above instructions:

qdbus org.kde.kded /kded org.kde.kded.{something} with

qdbus org.kde.kded5 /kded org.kde.kded5.{something}

See also : Fedora - Kscreen, Arch Linux Forums

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .