Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is very annoying. Somehow I activated the 'single application' mode on Snow Leopard and it doesn't show more than one window on the desktop.

I've searching for a solution and trying that Terminal fix but it won't work.

Does someone know how can I fix this?

share|improve this question
    
Snow Leopard doesn't have a "Single Application" mode, as far as I know. – Wuffers Jun 27 '11 at 6:06
    
@Mark-Szymanski Single Application mode only allows one window to be active at a time while the rest are banished to the background... they are still running, just not visible... – Dustin G. Jun 27 '11 at 6:57

Terminal:

defaults write com.apple.dock single-app -bool false
killall dock

Edit:

Since this does not seem to work for you, I would recommend going into /Library/Preferences in your user folder and deleting com.apple.dock.plist and com.apple.dock.db and it will completely reset your dock since this is where the single-application mode preferences would reside.

Log out / Login or... Reboot

** You will have to add applications / change prefrences for your dock because it will revert to default**

share|improve this answer
    
I tried that and nothing happens. Is there any preference somewhere in Snow Leopard? – Pen Ya Jun 29 '11 at 19:10
    
There is no GUI for the preference... the only option is to change com.apple.dock to have single-app disabled... have you rebooted? – Dustin G. Jul 1 '11 at 2:09
    
Yes I have, several times. No luck thought. – Pen Ya Jul 2 '11 at 19:20
    
You are using "killall dock" as a separate command (not in line with the rest) correct? – Dustin G. Jul 4 '11 at 1:40
    
Yes I am. I'm first submitting write and then the killall for rebooting the dock. – Pen Ya Jul 4 '11 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .