Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my Debian installation I can type extended ASCII characters such as åäö by default using the terminus font, however in Gentoo I can't get it to work so far. Nothing happens when I hit those keys, like in this thread: Missing glyphs in Terminus font, how to setup a fallback font?

But in this case I know terminus supports those characters in at least some of its versions, since it works in Debian. So what I want is to find out how to see and choose which of the many different terminus font files is being used.

I set the font in the same way on both Debian and Gentoo, using URxvt*font: xft:terminus:size=xx in .Xdefaults. Both systems use en_US.UTF-8 as default locale.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Use the all-in-one font.

oldschool: urxvt -fn '-xos4-terminus-*-*-*-12-*'
xft:       xft:terminus-12:encoding=combined

/usr/share/consolefonts/README.terminus


names   mappings                covered codepage(s)

ter-1*  iso01, iso15, cp1252    ISO8859-1, ISO8859-15, Windows-1252
ter-2*  iso02, cp1250           ISO8859-2, Windows-1250
ter-7*  iso07, cp1253           ISO8859-7, Windows-1253
ter-9*  iso09, cp1254           ISO8859-9, Windows-1254
ter-c*  cp1251, iso05           Windows-1251, ISO8859-5
ter-d*  iso13, cp1257           ISO8859-13, Windows-1257
ter-g*  iso16                   ISO8859-16
ter-i*  cp437                   IBM-437
ter-k*  koi8r                   KOI8-R
ter-m*  mik                     Bulgarian-MIK
ter-p*  pt154                   Paratype-PT154
ter-u*  koi8u                   KOI8-U
ter-v*  all listed above        all listed above and many others (about 110
        and many others         language sets), 8 foreground colors

names   style

ter-*n  normal
ter-*b  bold
ter-*f  framebuffer-bold

http://keithp.com/~keithp/render/Xft.tutorial:

1.1 Xft Font Names

Xft font names can be represented in string form for storage in
configuration files or internally within applications, presenting these
names to the user is not quite as bad as using XLFD, but it's still less
polite than using a reasonable UI.  The format for Xft font names is:

    <family>-<size>:<name>=<value>...

An arbitrary set of additional elements can be appended to the font name,
the complete list of possible properties is:

    CPP constant        Name        Type
    ----------------------------------------------
    XFT_FAMILY      family      String
    XFT_STYLE       style       String
    XFT_SLANT       slant       Int
    XFT_WEIGHT      weight      Int
    XFT_SIZE        size        Double
    XFT_PIXEL_SIZE      pixelsize       Double
    XFT_ENCODING        encoding        String
    XFT_SPACING     spacing     Int
    XFT_FOUNDRY     foundry     String
    XFT_CORE        core        Bool
    XFT_ANTIALIAS       antialias       Bool
    XFT_XLFD        xlfd        String
    XFT_FILE        file        String
    XFT_INDEX       index       Int
    XFT_RASTERIZER      rasterizer      String
    XFT_OUTLINE     outline     Bool
    XFT_SCALABLE        scalable        Bool
    XFT_RGBA        rgba        Int

try bzcat /usr/share/doc/terminus-font-4.36/README.bz2 |less for more info.

share|improve this answer
    
Thank you for your answer. I didn't notice this before and haven't had this problem for a long time now, but it seems like a decent answer so I'll accept it. –  gaidal Sep 9 '13 at 10:02

Only thing I could think of is if you omitted the iso14755 USE flag, but I'm not entirely sure if that'll fix it.

share|improve this answer
    
I thought of that too, but compiling with it didn't help. –  gaidal Jun 29 '11 at 14:20
    
I suppose the best course of action is to dig into how Debian sets up user input with the keyboard and what their build of urxvt looks like. –  Corey Richardson Jun 30 '11 at 18:04
    
That flag is for Japanese input methods that no-one really knows anything about unless they are Japanese. Don't use it. –  Ярослав Рахматуллин Nov 29 '12 at 22:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.