Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While using MacVim to edit markdown files, when I enter the insert (i) or append (a) mode and type the grave ` character to start or end a line of code, MacVim switches to IM INSERT MODE and sometimes just overwrites the grave ` character. What is this mode and how can I prevent MacVim from overwriting the grave ` character?

share|improve this question

migrated from stackoverflow.com Jun 27 '11 at 9:53

This question came from our site for professional and enthusiast programmers.

    
I guess that's coming from a plugin. What does :imap ` return for you? –  sidyll Jun 25 '11 at 16:25
    
Hm, it returns No mapping found. Maybe Max OS X is causing the problem? –  wowpatrick Jun 25 '11 at 20:33
add comment

1 Answer

up vote 2 down vote accepted

` is a dead key in your active input method (keyboard layout).

IM INSERT is MacVim letting you know that you are using a Mac OS X input method mode where your keystrokes will probably be given special interpretation.

You can manage the available input methods in the Input Sources tab of the Language & Text preference pane in the System Preferences application (i.e. the > System Preferences… menu item). You will probably want to enable Show Input menu in menu bar at the bottom to make it easy to switch input methods (and enable the Keyboard Viewer where it is easy to see the dead keys (they are a different color)).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.