Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a server service that uses 8182 port. Somebody want to connect to this, but 8182 port is unavailable for him, only 5118 working fine.

No problem I thought, I just install port forwarder software (service), I set to: "If somebody is connecting to 5118, I redirect to 8182".

But I didn't find any trustable (and freeware) good software for this. I tried Rouvali Windows Port Forwarding Service, but it only shows an error on log.

I have no control over the router, because this is a virtual, leased server.

So please suggest me some freeware Windows service (application) that can redirect this port in persistent mode.


Hi!

The netsh was not really succesful.

First the netstat don't show the binded port.

But next I found this article:

http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/e794910b-9325-4ef9-be82-3e57925e6586/

This said that I need to install IPV6 support. Then I installed it, and restarted the server.

After this the netstat show the needed port, but on connect (locally or remote) I got:

Socket error: An existing connection was forcibly closed by the remote host. (10054), on API 'recv'

What would be the next step?

Thanks for your help: dd

share|improve this question
    
I solved this to use the outer IP, and not local... –  durumdara Jun 29 '11 at 8:03

5 Answers 5

up vote 5 down vote accepted
netsh interface portproxy add v4tov4 5118 127.0.0.1 8182
netsh interface portproxy add v6tov6 5118 ::1 8182

Note that the service will see the user as connecting from "localhost", which may be undesirable for logging purposes.

share|improve this answer
    
Hi! I type your example, but nothing happened. 1.) netstat don't show anything 2.) I cannot connect. May I must start a service, or do some restart, etc? Thanks! –  durumdara Jun 28 '11 at 6:56

You can also try:

netsh routing ip nat add portmapping "LAN NAME" tcp 0.0.0.0 5118 192.168.0.3 8182

Where 192.168.0.3 is the target server ip.

If port 5118 comes from internet this port has to be open in your firewall/router.

share|improve this answer

Neither of these worked for me. However the port of rinetd worked well. http://codewut.de/Port-Redirection-with-Windows

share|improve this answer
2  
Welcome to Superuser, could you post all relevant information to your answer from that link into your answer to avoid link rot –  50-3 Oct 1 '13 at 23:12
    
As @50-3 said, please include all relevant information. It's okay to link things, but include as much from the link in your answer as possible. One to two line answers are generally frowned upon. :C –  DanteTheEgregore Oct 1 '13 at 23:51

found on a forum :

You need to install IPv6 (Run->Settings->Control Panel->Network Connections->Local Area Connection->Properties->Install->Protocol->Microsoft TCP/IP version 6), otherwise this feature won’t work. It’s a known bug in netsh and it doesn’t look like Microsoft is going to fix it.

and here is the Microsoft KB article :

http://support.microsoft.com/kb/555744

share|improve this answer

"IP Helper" service must be enabled and running !

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.