Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have performed a fresh Windows 7 Ultimate 64-bit installation yesterday. The installation was a charm (as always). I successfully installed all the drivers and software that I needed without breaking a sweat. However, the last two applications are still missing: Internet Explorer 9 (don't ask me why I need it - we can't all share the same luck in this world :) and Windows Live Essentials 2011 Photo Gallery.

I went to the Microsoft's download site to get the web installers, but the download of those files fails each time. I get a "Page not found" message. It's pretty amazing really. So, I went to my father's who has different network and uses the services from a different ISP. The download links work normally. I completely lost my nerves and called my ISP to ask if they blacklisted downloads from Microsoft Download Center. It was quite impossible to even imagine such scenario, but I was desperate. Of course, they haven't blocked anything.

One more thing: I am always offered to download Windows Live Essentials through Windows Update. But it hasn't shown up since the system is set up. My copy of Windows is legit and activated.

Could anyone please try to explain to me why is my system avoiding the software from Microsoft? Thanks.

P.S. Internet access is working just fine in general. It's just that one damn site, and only if I want to download something. Cheers.

share|improve this question
What link are you using to download it? Are you running SP1? – KCotreau Jun 27 '11 at 18:06
Yeah, I am running SP1. I am using this link (I am choosing Windows 7 64-bit from the drop-down box) After clicking the Download button, the browser is waiting for a while and then it shows the Page Not Found. – Boris Jun 27 '11 at 18:13
Moab, thanks for the links. In the end, it was the IPv6 vs IPv4 that was causing the issue. I was able to install both apps only after that was fixed (the installations kept crashing even thought they were "offline installations"). Again, thanks for the links! – Boris Jun 27 '11 at 20:45
I posted them as backup so you would not commit computer suicide. ;-> – Moab Jun 27 '11 at 21:06
up vote 1 down vote accepted

Boris, try this link and see if you can get it:

Live Essentials:

We did a remote session, and the problem was the Teredo tunnel, related to IPv6. The solution was going to Device Manager, enabling hidden devices, then disabling it under Network Adapters solved the problem.

share|improve this answer
When I click Download on the page you have provided, it takes me to the "Thank you for downloading" page and then it waits for a while to get started with the download, but since nothing happens, the time-out fires and again, I am presented with the "Page not found" message. – Boris Jun 27 '11 at 18:23
I even tried to click that link "In case your download doesn't start..." but the outcome is the same. Oh, this is so frustrating... – Boris Jun 27 '11 at 18:24
My browser (Google Chrome) is not showing any pop-up blocking. I did as you suggested, but to no avail :/ – Boris Jun 27 '11 at 18:42
Yeah, I do have IE8 and all the ideas that I've had or the ones you've suggested I tried from both Google Chrome and Internet Explorer - but the problem remains. – Boris Jun 27 '11 at 19:13
Everyone, Kevin here was a true help and not only that he solved my issue, but he also made me learn some new stuff. Well done Kevin and thank you so very much! – Boris Jun 27 '11 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .