Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Western Digital Caviar Green 2TB hard drive will not mount in Windows 7 for some reason.

I loaded it into a SATA enclosure to see if I could partition it in Windows XP, and it says it's a healthy GPT protected partition. It won't mount on my Windows 7 computer though, so what can I do to get it working?

share|improve this question
    
what partition type? - i'm guessing if its GPT, it might be from a mac, and as such HFS+ –  Journeyman Geek Jun 28 '11 at 5:39
    
what versions are you OSs ?(32 or 64 ?) –  Shekhar Jun 28 '11 at 6:04
    
I have windows 7 32 bit. The HD I bought new from newegg. I tried formatting it into ntfs but it wouldn't mount after that. And now, when its viewed in disk management in xp it says GPT protected. >_< –  Vito Jun 28 '11 at 14:03

1 Answer 1

Not enough information to tell for certain, but enough to get started

XP detects the drive as a GPT protected partition, so that it won't accidentally do nasty MBR related things to it since the drive appears to be GPT based.

We don't know the filetype - the 'easiest' way would be to try to mount it on a linux livecd and check, maybe using unetbootin - the simplest way would be to use df -t in a terminal or You could use gparted for a graphical interface. If its NTFS, and its some random glitch, sometimes you can recover the data from linux and reformat.

Assuming we need to check in windows, and its an unsupported filetype, a good bet is HFS+ since OS X uses GPT by default (plausible, since most hard drives are still MBR formatted) you could check with HFS Explorer if its that, and what's there.

share|improve this answer
    
Thanks for your answer. It isn't a mac formatted hd. I bought it new from newegg and tried to format it in windows 7 after connecting it to my motherboard. I am thinking there was some sort of glitch because after I tried to format it with the guid option, it mounted but transferred data incredibly slow. When I restarted, it was not visible. –  Vito Jun 28 '11 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.