Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having issues getting SMB file shares working over a PPTP VPN.

The server setup consists of a security device (DrayTek V3300) which passes the PPTP authentication to a SBS2003 server running RRAS. The server is the DC and provides DNS and WINS, the single NIC's name server is set to the NIC's IP (192.168...), and DHCP on the DrayTek sets the server IP as the DNS.

If I create a new VPN connection in Win7, leaving everything as default apart from the server, username, password and domain, I can:

  • ping everything by IP address
  • resolve IPs with nslookup using their fully-qualified name, as in nslookup fileserver.mydomain.local
  • ping machines by fully-qualified name, as in ping fileserver.mydomain.local

However if I try to access a file share:

  • within Explorer, I get "Windows cannot access ..." with "Error code: 0x80004005 Unspecified Error",
  • using net use z: \\fileserver.mydomain.local\share, I get "System error 53 has occurred. The network path was not found."

If I add the machine name to my HOSTS file I can use the file share, which is my last-ditch workaround, but I have a number of VPN users and would rather a solution that doesn't involve me trying to hand-edit system files on computers half a country away.

If I set the WINS server explicitly in the connection's IPv4 settings I don't have to use the FQN to ping the machine, but that doesn't change anything else.

EDIT: The PC I'm having the issue on is running Win 7 Home Premium. After more testing I actually have two other PCs that work, one W7HP, one XP Home, and another Vista PC that doesn't work (not tested as much as the others), all four on the same internet connection (behind the same router). All of them were tested with a straight-forward, all defaults, new VPN configuration.

share|improve this question
add comment

2 Answers

I would try moving the VPN connection to the top of the binding order:

You don't say what version of Windows, so just get to your network connections, then click Advanced>Advanced settings and move [Remote Access connections] to the top. In my book, that is always a first step in troubleshooting VPN resolution issues.

I hate those network not found errors. They are VERY annoying. You can also try this if using XP

http://compnetworking.about.com/b/2005/10/02/the-network-path-was-not-found.htm

http://randomtech.blogspot.com/2007/07/network-path-was-not-found-error-on-win.html

For the record, the DNS settings on your server should not point to 127.0.0.1, but to its actual IP address. Frankly, I still don't see the difference, and I also did it that way for years, but Microsoft tech, after Microsoft tech has told me to set it to the actual IP address.

share|improve this answer
    
Thanks. Changing the binding order didn't make any difference, it is Win 7 so I tried resetting WinSock as suggested in the comments of that link then restarting but that didn't work, and I changed the DNS of the server's NIC to point to the NIC's IP address (192.168...), also no good. Thanks anyway :-) –  Ben Scott Jun 28 '11 at 12:51
add comment

You probably need to use your DC as your local system's DNS server for the VPN connection. That way it can resolve hostnames on the VPN instead of relying on however Windows discovers hosts without DNS. You can try this manually by going into ncpa.cpl, selecting your PPTP VPN virtual network adatper, and modifying the DNS server to point to that of your DC.

I'm not overly familar with how setting up PPTP connections works on the server side but basically you want to enable whatever option "pushes" this DNS address to clients.

This will have the side effect of routing all that local systems DNS traffic to your DC while the VPN is up.

share|improve this answer
    
I tried setting the DC as the VPN connection's DNS server but it didn't have any difference. DHCP assigns the correct server as DNS anyway. I can route all DNS to the DC by enabling 'Use default gateway on remote network' but that doesn't help, it just kills external DNS queries. I'm not convinced it's a DNS issue, as nslookup and ping can resolve the FQN, but SMB can't. Thanks anyway. –  Ben Scott Jul 12 '11 at 0:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.