Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Can gedit on mac be used to edit files over ssh?

I've been able to do this in the past but completely forgot how to call it!

I'm using OSX and looking to edit a file in terminal (over ssh). Istead of using emacs or vim I was able to open the file in gedit. I've seen around the web the open command but I'm sure it wasn't that, and also I keep getting "command not found" when I try to use it anyway. Can anyone help me out?

share|improve this question

marked as duplicate by grawity, Sathya Jun 28 '11 at 11:29

This question was marked as an exact duplicate of an existing question.

Are you SSH'ing to or from OS X? – grawity Jun 28 '11 at 9:36
From OSX to debian. I ended up using nano on the server, but I'm sure I've been able to open files up in TextEdit or Gedit before in the past. Even if it was only locally. – ing0 Jun 28 '11 at 10:11

Two possible methods:

  1. TextEdit or Gedit running locally.

    • Using sshfs: Install MacFUSE, use the sshfs command to mount the remote file system locally. There's a GUI named MacFusion, if I remember correctly.

    • Using Gedit's SFTP support. On Linux, Gedit accepts such URLs as sftp://server/filename. (But to be honest, I don't even know if the same Gedit works on OS X.)

  2. Using Gedit remotely. The SSH protocol supports forwarding of X11 connections, so you can install the program on your Debian server, then connect using ssh -Y servername and just run gedit myfile over SSH.

    You'll also need to have an X11 server running on OS X (I think one is bundled), and X11 forwarding enabled in sshd_config on Debian.

There is another question on the same topic.

share|improve this answer

Not sure about OSX, but between debian machines this normally works

ssh -X user@host

Otherwise it might not tunnel X.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .