Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ours is a windows network. There are some systems with Windows 7 and some with Windows XP. Mine is a Windows 7 system. I would like to create a user group so that I can grant it permission to access shared folders.

  • In the sharing dialogue (Right click -> Properties -> Sharing -> Advanced sharing) I can see option to select users or groups. ("Select users, computers, service accounts, or groups" dialogue -> Find now displays a list of computers and groups to select. )

  • Also, I can specify the types of objects I want to look for -> options contains Object types -> users, groups etc.

But there is no option to create a group.

Do I need to create from Control Panel -> Network and Internet ? I read about creating a homegroup but it does not look like what I want -

If your computer belongs to a domain, you can join a homegroup but you can't create one. You can access files and resources on other homegroup computers, but you can't share your own files and resources with the homegroup.

How do I do this? Just want to create a group so as to share files among teammates. Why are simple things done so complex?

share|improve this question
    
What versions of Windows are you using specifically, the Home or Pro versions? And, just to clarify, you are in workgroup, not Microsoft domain? –  KCotreau Jun 28 '11 at 10:45
    
@KCotreau - all are Professional versions - both Windows 7 and XP –  Sandeepan Nath Jun 28 '11 at 12:06
    
@KCotreau - As seen in the network section of a Win XP system in the network, all our systems can be seen going to Entire Network -> Microsoft windows network -> <Our company's Network>. So all are not inside Workgroup. –  Sandeepan Nath Jun 28 '11 at 12:09

3 Answers 3

You can create user groups from:

  • Local User Manager:

    lusrmgr.msc
    
  • command-line:

    net localgroup Friends /add
    
    net user Joe Friends /add
    
share|improve this answer
    
I created a new group using lusrmgr.msc, added some users. But then while trying to share a folder, don't see that group in the options. If I open lusrmgr.msc again, I can see the group I have added. Any kind of restart of something is needed? Thanks btw –  Sandeepan Nath Jun 28 '11 at 10:22
    
Don't see that group while inside advanced sharing options... ("Select users, computers, service accounts, or groups" dialogue -> Find now –  Sandeepan Nath Jun 28 '11 at 10:29

There is only 2 way of adding group or user (as far as I know). With remote powershell to the AD, or directly on the AD!

You can't create group unless you contact your AD with powershell or RDP.

It's bothersome, but it'll keep user to do crap on the ad!

Connect on your AD, create the group you want, add user in this group, and add this group to your share NTFS permissions.

Hope this will help you.

share|improve this answer

OK, now that I have those clarifications, I can give you an answer.

First, you really do not want to use local users for this otherwise you would need to keep the passwords sychronized on both their account and the account you create for them on your computer. You want to use domain users.

You would need to add all the domain users to your local group. You will go into Control Panel>Administrative Tools>Computer Management>Local Users and Groups and add your new group (right-click, "New group"). You will add members by double-clicking the group and then clicking "add". Click the "Location" button and make sure your domain is where you are picking users from. Click the "Advanced" button and then "Find now". Select your users.

share|improve this answer
    
looks like I have already followed the steps which you have mentioned, (through lusrmgr.msc as answered by @grawity). But the problem is I am not getting the group created by me when I actually attempt to share a folder (in its "Advanced" -> "Find now"). I have checked again that I have selected only users from my domain, while inside the "Locations" option. –  Sandeepan Nath Jun 28 '11 at 12:32
    
Add some scren shots to your post. Not sure what you are doing, or not doing. –  KCotreau Jun 28 '11 at 13:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.