Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Why do I get this message on Windows XP SP3?:

https://sni.velox.ch/

"Unfortunately, your client [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18 ( .NET CLR 3.5.30729)] did not send a TLS server name indication extension (RFC 4366) in its ClientHello (negotiated protocol: SSLv3), so you're probably getting warnings about certificate name mismatches."

When I visit the mentioned site with Firefox.

So this means that Firefox doesn't supports SNI? Or What? :O

p.s.: it's related to: How to test that SNI is supported by given webbrowser?

share|improve this question
2  
Using Firefox 5.0 on Win XP SP3 and I get a positive result, could just be an "old version of Firefox" issue since I see 3.6.18 in your user agent string. – DMA57361 Jun 28 '11 at 9:54

Under ToolsOptionsAdvancedEncryption, make sure you have "Use TLS 1.0" enabled. This is off by default in older versions of Firefox. UPGRADE!

share|improve this answer
    
Thank you. The Firefox version is 3.6.18 and I checked it, it was disabled! After enabling TLS 1.0 the test still doesn't works!! Why? :O – LanceBaynes Jun 30 '11 at 8:14
    
Try clearing the cache - most browsers remember the SSL settings they used for websites. – grawity Jun 30 '11 at 8:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .