Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried googling this but without any success. Everyone seems to be telling stories like the one below:

So tonight I was about to watch a new promotional video, but I forgot to turn down the volume before I put my headphones in. As soon as they're plugged in, the volume jumps to 100% and I damned near blow my ear drums out.

It was simple on my DELL. Whatever volume you set it, it'd stay there despite whatever you plugged into the headphone port.

However, with OS X it seems you can set the volume to 20%, but as soon as you plug something into the headphone port, the audio will jump to a preset volume. For mine it seems to be 100%.

Where is the option to correct these? I'd rather have the defaults set to 10%...

I can confirm on a MBP running OS X 10.6.7 that this is still happening. Has anyone found a solution?

share|improve this question
    
Apple considers this a feature where you can set the volume for separate outputs. The problem comes when you use the headphone out for multiple devices (for example, using speakers and headphones from the headphone jack). –  viking Jun 28 '11 at 13:14
    
I think it is a good idea, it just does not work correctly. Every time I plug in my headphones I have to turn the volume down (to 1 bar). Then, if I unplug, the computer sleeps, wakes, and I re-plug them, the volume goes to 50% or so, which is too loud for my headphones. There has to be a way to set the "default volume" that is set when the headphones are reconnected - OS X is not remembering my last used value. I'm not using any other devices with the jack. –  cwd Jun 28 '11 at 15:45
    
I couldn't recreate the whole "unplug → sleep → wake → replug → resets to ~50%" phenomenon. But did you try sudo rm /Library/Preferences/Audio/com.apple.audio.DeviceSettings.plist /Library/Preferences/Audio/com.apple.audio.SystemSettings.plist? –  ؘؘؘؘ Jun 29 '11 at 12:21

2 Answers 2

From another forum I see this command sets the volume: works for me.

osascript -e 'set volume N'

Where N is 0, 1, 2, 3, whatever level is desired

I think this is only terminal code, actually.

share|improve this answer
up vote 1 down vote accepted

I'm not sure what causes this or the way to set the correct default values in the system, however I seem to have found a workaround that will do the trick, and it's called BreakAway:

enter image description here

It was basically designed to pause iTunes when you disconnect your headphones, but it also has a plugin option where you can run applescripts on events like connect and disconnect:

enter image description here

I've bound two events, connect and disconnect, to two applescript files which set the volume:

Set volume to about half way:

set volume 3
delay 2
set volume 3

Set volume to 2 bars:

set volume 1
delay 2
set volume 1

There is a multiplier for the number of bars, so setting the volume to "1" means 2 bars.

Here is a useful script snippet to demonstrate this:

display dialog ¬
    "Enter number." with title ¬
    "Number Of Squares?" buttons {"Set"} ¬
    default button 1 default answer ""
set numberSquares to text returned of result
set numberHalved to numberSquares / 2
set volume numberHalved

via http://hints.macworld.com/article.php?story=20100226174946948

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.