Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have phpMyAdmin 3.4.2 setup on a Windows 7 system. And following versions of PHP and Mysql are installed -

  • PHP Version 5.3.6
  • mysqlnd 5.0.8-dev - 20102224 - $Revision: 308673 $ (appears in the Client API version section of phpinfo())

The section Currently phpMyAdmin can: in the PMA documentation (following the documentation link of my PMA installation) displays the following-

  • create PDF graphics of your Database layout

Which means PDF graphics is viewing is supported in the version I am using.

But I am not able to see any option in the PMA UI to visualize the Db architecture. I made a fresh db, created two tables and added a foreign key constraint linking these two tables. Where does the option/tab to visualize appear?

What am I missing? Any ideas?

Thanks

Update
Following are the dbs present -

show databases; ->
+--------------------+
| Database           |
+--------------------+
| information_schema |
| lab                |
| mysql              |
| openx              |
| test               |
+--------------------+

Further Update
I executed the create_tables.sql file successfully and saw a new table phpmyadmin created, having 10 tables, i.e. pma_pdf_pages etc. Then I followed config storage doc. I was not having any config.inc.php. I renamed the config.sample.inc.php to config.inc.php, verified that the file is being loaded and then uncommented these lines -

 $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
 $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

Still not getting the designer tab.

Update 3
Uncommented all these lines in config file -

/* Storage database and tables */
 $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
 $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
 $cfg['Servers'][$i]['relation'] = 'pma_relation';
 $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
 $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
 $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
 $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
 $cfg['Servers'][$i]['history'] = 'pma_history';
 $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
 $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
 $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
share|improve this question

2 Answers 2

up vote 2 down vote accepted

After you've selected the database, there should be a "Designer" tab at the top, between "Import" and "Operations" on my install.

share|improve this answer
    
That tab is not there. I have Export, Import and More tabs. –  Sandeepan Nath Jun 28 '11 at 13:51
    
Looks like you need the "phpmyadmin" db... is that present on your system? –  baraboom Jun 28 '11 at 13:56
    
Please check my update. Where should this db be present? –  Sandeepan Nath Jun 28 '11 at 14:30
1  
Right, in order for the designer tab to be available (and other features, like database table tracking), you need to install the phpmyadmin database which stores the results of these extended phpmyadmin features. Here is their wiki page: wiki.phpmyadmin.net/pma/Configuration_storage. If that is not enough by itself, hopefully it will point you in the right direction. –  baraboom Jun 28 '11 at 14:34
    
your answer sounds correct, so a +1, but still I could not successfully bring up the designer tab. Please check my Further Updates section. –  Sandeepan Nath Jul 6 '11 at 9:11

The 'Designer' Tab needs to be enabled on WAMP, MAMP, and maybe LAMP setups. It involves editing a config file depending upon which operating system you use. There's a tutorial here http://debian.sreenadh.in/2008/11/28/how-to-enable-designer-in-phpmyadmin/ or you can just google 'Enable Designer Tab phpmyadmin' to find other resources specific to your OS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.