Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install planet, but I get an error:

/Users/john/Projects/planetprocessing/planet-2.0/planet/__init__.py:33: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Traceback (most recent call last):
  File "setup.py", line 7, in <module>
    from planet import __version__ as VERSION
  File "/Users/john/Projects/planetprocessing/planet-2.0/planet/__init__.py", line 35, in <module>
    import dbhash
   File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/dbhash.py", line 8, in <module>
     import bsddb
   File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/bsddb/__init__.py", line 64, in <module>
     import _bsddb
ImportError: No module named _bsddb
share|improve this question

migrated from stackoverflow.com Jun 28 '11 at 14:38

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

Try to have a look there, it seems there are problems installing correctly bsddb module on Mac OS X.

If you follow the patch described there, you should be able to use bsddb module.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.