Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Parallels installed on my Mac and I have created a Fedora 11 Virtual Machine. Everything works fine, except that the file sharing between my Mac and the VM doesn't work. On Parallels doc, they say I have to disable SELinux to make shared folders work.

How do I disable SELinux on Fedora 11?

Another thing the documentation says (and it doesn't work as well) is to configure in fstab:

none /media/psf prl_fs default,share 0 0

But when I try to mount this unit, I get a wrong fs type message.

Does anybody knows what I should do?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If you open /etc/selinux/config you will see a line that says:

SELINUX=enforcing

change it to:

SELINUX=disabled

to disable SELinux.

An unknown filesystem type message means the parallels file system driver is not loaded. Can you paste the output of the lsmod command ?

share|improve this answer
    
in fact prl_fs module is not installed. How do I install it? –  Daniel Cukier Aug 27 '09 at 0:16
    
You need to install Parallels Tools –  John T Aug 27 '09 at 0:39

Inside the VM, edit the file /etc/selinux/config SELINUX directive to disabled, like this:

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#       targeted - Targeted processes are protected,
#       mls - Multi Level Security protection.
SELINUXTYPE=targeted
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.