Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Windows 7 Professional 64bit PPTP VPN (using the built in networking client)

I'm connecting to my home VPN server from my work computer. This previously worked without issues using Windows XP, but since my workplace has migrated to 7, I'm seeing this issue:

I can connect and use the VPN connection without any problems. I can RDP to my home computers, access network shared, etc without issues. Windows 7 seems to make the VPN connection the default for everything, which is not working for certain things on the work PC. Namely, when I connect to the VPN I can't access our database servers (I would assume because Windows is looking for them at my house via the VPN connection).

This isn't necessarily a huge problem if I'm sitting at my work computer and can switch the VPN on and off, but I do use the VPN connection to remote desktop to my work PC from home (using the VPN backwards in a way). I can activate the VPN connection remotely without issue and RDP to the work computer without issues. So I can't access work resources when remotely connected to my work PC via the VPN connection.

Since my company doesn't use RDP for anything, I could just say all RDP traffic should use the VPN and be fine. Little Help?

share|improve this question
add comment

1 Answer

Go to Control Panel>Network and Sharing Center>Change adapter settings.

Then right-click your VPN connection, and click Properties>Networking>Double-click TCP/IPv4 (you can probably uncheck TCP/IPv6 while you are there)>Advanced

Uncheck "Use default gateway on the remote network".

This should solve your problem.

share|improve this answer
    
Doing this won't break my work stuff, but I can't RDP or access other network resources at home. –  Jeff Jun 28 '11 at 19:32
    
Is that a question? "Doing this won't break my work stuff". –  KCotreau Jun 28 '11 at 19:52
    
Nope, a statement. This does not solve my issue. –  Jeff Jun 28 '11 at 20:25
1  
@Jeff That first sentence, "both networks use 192.168.1.xx internally", maybe your problem, but probably not: Most VPN servers know how to deal with both being the same network. You say they both use 192.168.1.x internally, then your home VPN server is serving up addresses on a different network. You can either have it give out addresses on your 192.168.1.x network, or you need try adding a route add statement similar to this on your work computer, but I think that might cause more problems. Try changing the addresses your VPN server gives out if it is on the same switch as your home computer. –  KCotreau Jun 29 '11 at 18:54
1  
If they are actually on disparate networks, you only have two options, and one is keeping that gateway option checked, but you will always be cut off locally; or you can add the route statement, but because you are on the same 192.168.1.x network, add it could cause routing problems when you are not connected to the VPN. Put the VPN on the same 192.168.1.x network, or change your home network to a different one, like 192.168.50.x and then you can certainly add a persistent route with no ramifications. –  KCotreau Jun 29 '11 at 18:57
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.