Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you prevent a user from logging into Windows 7 when another user has locked the computer?

share|improve this question

5 Answers 5

Open gpedit.msc from either the Run prompt or from the Search box.

Under Local Computer Policy, go to Computer Configuration -> Administrative Templates -> System -> Logon

enter image description here

Select the entry that says: Hide entry points for Fast User Switching

enter image description here

Open that entry and select Enabled to not allow other users to log on while the computer is locked.

enter image description here

share|improve this answer

Disable user switching. Possible on domain computers and maybe others. see here

Click the Start button , type gpedit.msc in the search box, and then press Enter. If you're prompted for an administrator password or confirmation, type the password or provide confirmation. Under Computer Configuration, click the arrow next to Administrative Templates, and then click the arrow next to System. Click the Logon folder. Double-click Hide entry points for Fast User Switching Properties, click Enabled, and then click OK.

share|improve this answer

You need to disable something known as Fast User Switching. I could have sworn that this was possible in the GUI, but I can't seem to find the option anywhere.

It can still be done from Group Policy editor in Professional / Enterprise / Ultimate editions (not sure about others).

You can do it by:

  1. Press Windows Flag+R .

  2. Type gpedit.msc.

  3. Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.

  4. Then open Set Hide entry points for Fast User Switching.

  5. Set this to Enabled.

  6. Reboot your machine.

And you are done!

share|improve this answer

just make the user a member of "Power Users" group instead of "Administrators" group

share|improve this answer

You can check if this works for you (it did for me): http://www.askvg.com/how-to-disable-switch-user-option-in-windows-vista-and-7/

Not sure if there is a way around it but the button does not appear.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.