Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some weird problem happened to my Maxtor 500GB external harddisk, it all started when it once freezed during some operation. Now when I insert the drive in a USB slot, Windows asks me to format it, and if I try to open the drive from my computer it says, "not accessible"..

I tried most of the major partition managers and partition recovery software. All of these can see and access my partition normally. It showing the free space and used space correctly. But Windows can't. Please help me out.

Including a screenshot: On the left side, the partition manager can access and see my data in the corrupted partition, and on the right side Windows can't

snapshot

share|improve this question

2 Answers 2

You could try running the Seatools diagnostic software. It's from Seagate but they now own Maxtor.

share|improve this answer
    
seatools says everything is fine!!. but its not.. chkdsk /f driveletter: fixed it.. now i can access the files normally but only from the computer i run the command with, other computers says the same thing. to format it... its strange. now i am copying all the data to a different EHDD, will format it after that. –  Ashish Jun 30 '11 at 6:55

I would try to repartition it and reformat from Ubuntu LiveCD.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.