Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 in a Parallels Desktop 6 on Mac.

On the mac, I use /etc/hosts:

127.0.0.1 mysite

and it works fine; I can type mysite in the URL box and the website will display.

What I want to do is be able to reproduce the same on Win7 with IE8, for example.

Another guy on Server Fault has done it successfully, here but I can't.

On Mac, I've done this:

ifconfig -a  

vnic0 10.211.55.2

On Windows 7, I tried this

 C:\Windows\System32\drivers\etc\hosts

10.211.55.2 mysite

What am I missing?

share|improve this question

migrated from serverfault.com Jun 29 '11 at 8:07

This question came from our site for professional system and network administrators.

    
@JdeBP thanks for the flag WRT the OP needing to accept an answer, but there's nothing the mod team can do. We cannot force an accepted answers - ever. The only way this question will get an accept is if the user registers on both SF and SU, and links their accounts, to get ownership of the question back and then they can accept an answer themselves. –  DMA57361 Jun 29 '11 at 11:17
    
I suggested help, to a new user who had posted an acceptance as another answer, rather than force. –  JdeBP Jun 29 '11 at 12:05

1 Answer 1

if you use apache for your test web site, you need to bind (listen) first ip:port 10.211.55.2:80 in httpd.conf to make it work.

Add this row in httpd.conf (You can find first 127.0.0.1:80 and press new row after it)

Listen 10.211.55.2:80
share|improve this answer
    
Bingo ! I'm done, thank you for your help ;) –  user88092 Jun 29 '11 at 10:40
    
@ling, if you want to re-gain ownership of this question (so you can accept an answer, comment, etc) then please note that you need to register on SF and SU and link your accounts. –  DMA57361 Jun 29 '11 at 11:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.